summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/easygui/easygui.SlackBuild8
-rw-r--r--development/pychecker/pychecker.SlackBuild10
-rw-r--r--development/re2c/re2c.SlackBuild8
-rw-r--r--graphics/unpaper/unpaper.SlackBuild8
-rw-r--r--libraries/c++-gtk-utils/c++-gtk-utils.SlackBuild10
-rw-r--r--libraries/fltk/fltk.SlackBuild8
-rw-r--r--libraries/fltk13/fltk13.SlackBuild8
-rw-r--r--libraries/hdf5/hdf5.SlackBuild8
-rw-r--r--libraries/reportlab/reportlab.SlackBuild8
-rw-r--r--libraries/xforms/xforms.SlackBuild8
-rw-r--r--network/efax-gtk/efax-gtk.SlackBuild10
-rw-r--r--network/pyzor/pyzor.SlackBuild8
-rw-r--r--network/sniffjoke/sniffjoke.SlackBuild12
-rw-r--r--office/flowkeeper/flowkeeper.SlackBuild8
-rw-r--r--office/htmldoc/htmldoc.SlackBuild8
-rw-r--r--python/Pygments/Pygments.SlackBuild8
-rw-r--r--python/pydblite/pydblite.SlackBuild8
-rw-r--r--python/pyflakes/pyflakes.SlackBuild8
-rw-r--r--python/pyfltk/pyfltk.SlackBuild12
-rw-r--r--python/pytables/pytables.SlackBuild12
-rw-r--r--python/python-pmw/python-pmw.SlackBuild8
-rw-r--r--system/ecofont-ttf/ecofont-ttf.SlackBuild10
-rw-r--r--system/irqbalance/irqbalance.SlackBuild8
-rw-r--r--system/openct/openct.SlackBuild8
-rw-r--r--system/pcsc-perl/pcsc-perl.SlackBuild8
25 files changed, 117 insertions, 103 deletions
diff --git a/development/easygui/easygui.SlackBuild b/development/easygui/easygui.SlackBuild
index 68d266800b..25dfad377a 100644
--- a/development/easygui/easygui.SlackBuild
+++ b/development/easygui/easygui.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=easygui
VERSION=${VERSION:-0.96}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,11 +67,11 @@ mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_${SRC_VERSION}.tar.gz
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# install .py source file and sample file
python ./setup.py build install --root=$PKG
diff --git a/development/pychecker/pychecker.SlackBuild b/development/pychecker/pychecker.SlackBuild
index 31ebc7bf94..b864555786 100644
--- a/development/pychecker/pychecker.SlackBuild
+++ b/development/pychecker/pychecker.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pychecker
-# Copyright 2010-2011 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2010-2011 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pychecker
VERSION=${VERSION:-0.8.19}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,7 +52,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# setup.py modifications to avoid docfiles' installation in pythondir
sed -i "s|'data_files'|#'data_files'|g" setup.py
diff --git a/development/re2c/re2c.SlackBuild b/development/re2c/re2c.SlackBuild
index 7b80b233ab..bb235f5a2e 100644
--- a/development/re2c/re2c.SlackBuild
+++ b/development/re2c/re2c.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=re2c
VERSION=${VERSION:-0.13.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,11 +66,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# --htmldir= is ignored
CFLAGS="$SLKCFLAGS" \
diff --git a/graphics/unpaper/unpaper.SlackBuild b/graphics/unpaper/unpaper.SlackBuild
index 6877385699..aa7c76fd13 100644
--- a/graphics/unpaper/unpaper.SlackBuild
+++ b/graphics/unpaper/unpaper.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=unpaper
VERSION=${VERSION:-0.4.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -58,11 +58,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/libraries/c++-gtk-utils/c++-gtk-utils.SlackBuild b/libraries/c++-gtk-utils/c++-gtk-utils.SlackBuild
index ef69f2bd5a..f47ac77ace 100644
--- a/libraries/c++-gtk-utils/c++-gtk-utils.SlackBuild
+++ b/libraries/c++-gtk-utils/c++-gtk-utils.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=c++-gtk-utils
VERSION=${VERSION:-2.0.20}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,11 +66,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Used correct configure for gtk+2
CFLAGS="$SLKCFLAGS" \
diff --git a/libraries/fltk/fltk.SlackBuild b/libraries/fltk/fltk.SlackBuild
index 69b18f7310..a0e106305b 100644
--- a/libraries/fltk/fltk.SlackBuild
+++ b/libraries/fltk/fltk.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=fltk
VERSION=1.1.10
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -67,7 +67,11 @@ rm -rf $PRGNAM-$VERSION
tar xjf $CWD/$PRGNAM-$VERSION-source.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix underlinking.
patch -p1 -i $CWD/fltk-1.1.10-pkgconfig_xft.patch
diff --git a/libraries/fltk13/fltk13.SlackBuild b/libraries/fltk13/fltk13.SlackBuild
index 98911133ec..13e042b643 100644
--- a/libraries/fltk13/fltk13.SlackBuild
+++ b/libraries/fltk13/fltk13.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=fltk13
VERSION=${VERSION:-1.3.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -68,11 +68,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION-source.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix linking when --libdir=/usr/lib64
sed -i \
diff --git a/libraries/hdf5/hdf5.SlackBuild b/libraries/hdf5/hdf5.SlackBuild
index 48f82f4f80..b0b3546536 100644
--- a/libraries/hdf5/hdf5.SlackBuild
+++ b/libraries/hdf5/hdf5.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=hdf5
VERSION=${VERSION:-1.8.11}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,11 +67,11 @@ rm -rf $PRGNAM-$SRCVERSION
tar xvf $CWD/$PRGNAM-$SRCVERSION.tar.?z*
cd $PRGNAM-$SRCVERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# --with-ssl option removed
CFLAGS="$SLKCFLAGS" \
diff --git a/libraries/reportlab/reportlab.SlackBuild b/libraries/reportlab/reportlab.SlackBuild
index a4d6b9d70e..24c8296581 100644
--- a/libraries/reportlab/reportlab.SlackBuild
+++ b/libraries/reportlab/reportlab.SlackBuild
@@ -26,7 +26,7 @@
PRGNAM=reportlab
VERSION=${VERSION:-2.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,11 +67,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Generate pdf documentation
( cd docs
diff --git a/libraries/xforms/xforms.SlackBuild b/libraries/xforms/xforms.SlackBuild
index f1c9fde82c..8102386b0a 100644
--- a/libraries/xforms/xforms.SlackBuild
+++ b/libraries/xforms/xforms.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=xforms
VERSION=${VERSION:-1.0.93sp1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -70,11 +70,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/network/efax-gtk/efax-gtk.SlackBuild b/network/efax-gtk/efax-gtk.SlackBuild
index 2e2ee778be..2d901c4bdd 100644
--- a/network/efax-gtk/efax-gtk.SlackBuild
+++ b/network/efax-gtk/efax-gtk.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=efax-gtk
VERSION=${VERSION:-3.2.12}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,11 +70,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.src.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/network/pyzor/pyzor.SlackBuild b/network/pyzor/pyzor.SlackBuild
index b478931ba1..a962a9ec6f 100644
--- a/network/pyzor/pyzor.SlackBuild
+++ b/network/pyzor/pyzor.SlackBuild
@@ -26,7 +26,7 @@
PRGNAM=pyzor
VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -56,11 +56,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/better-py27-compat.patch
diff --git a/network/sniffjoke/sniffjoke.SlackBuild b/network/sniffjoke/sniffjoke.SlackBuild
index 0e996c1485..3210eccb5f 100644
--- a/network/sniffjoke/sniffjoke.SlackBuild
+++ b/network/sniffjoke/sniffjoke.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=sniffjoke
VERSION=${VERSION:-0.4.2_aa2a003}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,11 +67,11 @@ rm -rf $SRCNAM-$GITSRCVERSION
tar xvf $CWD/$SRCNAM-$GITSRCVERSION.tar.gz
cd $SRCNAM-$GITSRCVERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Unfortunately most options for destination directories are not
# available so we have to manually replace some values before cmake.
diff --git a/office/flowkeeper/flowkeeper.SlackBuild b/office/flowkeeper/flowkeeper.SlackBuild
index e4f413c1f0..447ea7eddb 100644
--- a/office/flowkeeper/flowkeeper.SlackBuild
+++ b/office/flowkeeper/flowkeeper.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=flowkeeper
VERSION=${VERSION:-2010.12}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
ARCH=noarch
@@ -42,11 +42,11 @@ rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Jar file
mkdir -p $PKG/usr/share/$PRGNAM
diff --git a/office/htmldoc/htmldoc.SlackBuild b/office/htmldoc/htmldoc.SlackBuild
index 42ba6aed6b..432d19fc8f 100644
--- a/office/htmldoc/htmldoc.SlackBuild
+++ b/office/htmldoc/htmldoc.SlackBuild
@@ -27,7 +27,7 @@
PRGNAM=htmldoc
VERSION=1.8.27
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-5}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -68,11 +68,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-source.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# workaround to avoid /usr/share/doc/htmldoc's use for help function
sed -i 's|^#define DOCUMENTATION "$prefix/share/doc/htmldoc"|\
diff --git a/python/Pygments/Pygments.SlackBuild b/python/Pygments/Pygments.SlackBuild
index 90ddea2669..a082f9e38d 100644
--- a/python/Pygments/Pygments.SlackBuild
+++ b/python/Pygments/Pygments.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=Pygments
VERSION=${VERSION:-1.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,11 +52,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr --root=$PKG
diff --git a/python/pydblite/pydblite.SlackBuild b/python/pydblite/pydblite.SlackBuild
index ea657bb32c..7686037e45 100644
--- a/python/pydblite/pydblite.SlackBuild
+++ b/python/pydblite/pydblite.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pydblite
VERSION=${VERSION:-2.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,11 +54,11 @@ rm -rf $SRCNAM-$VERSION
unzip $CWD/$SRCNAM-$VERSION.zip
cd $SRCNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --root=$PKG
diff --git a/python/pyflakes/pyflakes.SlackBuild b/python/pyflakes/pyflakes.SlackBuild
index c23a589577..07740d4781 100644
--- a/python/pyflakes/pyflakes.SlackBuild
+++ b/python/pyflakes/pyflakes.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pyflakes
VERSION=${VERSION:-0.7.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,11 +51,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr/ --root=$PKG
diff --git a/python/pyfltk/pyfltk.SlackBuild b/python/pyfltk/pyfltk.SlackBuild
index b6223fec46..f1f5dbff74 100644
--- a/python/pyfltk/pyfltk.SlackBuild
+++ b/python/pyfltk/pyfltk.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyfltk
-# Copyright 2006-2010 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2006-2010 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,15 +24,13 @@
PRGNAM=pyfltk
VERSION=${VERSION:-1.1.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -59,7 +57,11 @@ rm -rf $SRC_PRGNAM-$VERSION
tar -xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
cd $SRC_PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Copy documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/pytables/pytables.SlackBuild b/python/pytables/pytables.SlackBuild
index 9cae7b71d9..51c0e3d9d3 100644
--- a/python/pytables/pytables.SlackBuild
+++ b/python/pytables/pytables.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pytables
-# Copyright 2007-2013 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-2013 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pytables
VERSION=${VERSION:-3.0.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,11 +67,11 @@ rm -rf $SRC_PRGNAM-$VERSION
tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
cd $SRC_PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --prefix=/usr --root=$PKG
diff --git a/python/python-pmw/python-pmw.SlackBuild b/python/python-pmw/python-pmw.SlackBuild
index dc132098c9..cb8ddcc317 100644
--- a/python/python-pmw/python-pmw.SlackBuild
+++ b/python/python-pmw/python-pmw.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python-pmw
VERSION=${VERSION:-1.3.3a}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,11 +66,11 @@ cd $PRGNAM-$VERSION
tar xvf $CWD/${SRCPRGNAM}_${SRCVERSION}.tar.gz
cd $SRCPRGNAM/$SRCPRGNAM
chown -R root:root . || true
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Move documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/system/ecofont-ttf/ecofont-ttf.SlackBuild b/system/ecofont-ttf/ecofont-ttf.SlackBuild
index 2ac2e565a0..bef0e17942 100644
--- a/system/ecofont-ttf/ecofont-ttf.SlackBuild
+++ b/system/ecofont-ttf/ecofont-ttf.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ecofont-ttf
-# Copyright 2009 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2009 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=ecofont-ttf
VERSION=2.02
ARCH=noarch
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -45,7 +45,11 @@ mkdir -p $TMP/$PRGNAM-$VERSION
cd $PRGNAM-$VERSION
unzip $CWD/$SRC_PRGNAM.zip
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Installing font
mkdir -p $PKG/usr/share/fonts/TTF
diff --git a/system/irqbalance/irqbalance.SlackBuild b/system/irqbalance/irqbalance.SlackBuild
index 2113b37f6d..2743aeab10 100644
--- a/system/irqbalance/irqbalance.SlackBuild
+++ b/system/irqbalance/irqbalance.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=irqbalance
VERSION=${VERSION:-1.0.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,11 +66,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root.root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/system/openct/openct.SlackBuild b/system/openct/openct.SlackBuild
index 63544bd091..7bf7fb014a 100644
--- a/system/openct/openct.SlackBuild
+++ b/system/openct/openct.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=openct
VERSION=${VERSION:-0.6.20}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -68,11 +68,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# building API doc
case "$APIDOC" in
diff --git a/system/pcsc-perl/pcsc-perl.SlackBuild b/system/pcsc-perl/pcsc-perl.SlackBuild
index 1dd55d9f0b..dbbab92934 100644
--- a/system/pcsc-perl/pcsc-perl.SlackBuild
+++ b/system/pcsc-perl/pcsc-perl.SlackBuild
@@ -26,7 +26,7 @@
PRGNAM=pcsc-perl
VERSION=${VERSION:-1.4.13}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,11 +66,11 @@ cd $TMP
tar xfv $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root.root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
perl Makefile.PL \
PREFIX=/usr \