summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/psutil/README4
-rw-r--r--python/psutil/psutil.SlackBuild5
-rw-r--r--python/psutil/psutil.info6
3 files changed, 10 insertions, 5 deletions
diff --git a/python/psutil/README b/python/psutil/README
index 0b94eeec80..c6fc21eeb6 100644
--- a/python/psutil/README
+++ b/python/psutil/README
@@ -5,3 +5,7 @@ command line tools such as: ps, top, df, kill, free, lsof, netstat, ifconfig,
nice, ionice, iostat, iotop, uptime, pidof, tty, who, taskset, and pmap.
Optional: pysetuptools, python3.
+
+To install python3 bindings run the slackbuild with PYTHON3=yes.
+
+ # PYTHON3=yes ./psutil.SlackBuild
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index 913d418baa..7503837b6e 100644
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-3.2.2}
+VERSION=${VERSION:-3.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,7 +57,8 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import os' 2>/dev/null); then
+# Install python3 bindings for psutil. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi
diff --git a/python/psutil/psutil.info b/python/psutil/psutil.info
index f29de0701b..c08fdecf40 100644
--- a/python/psutil/psutil.info
+++ b/python/psutil/psutil.info
@@ -1,8 +1,8 @@
PRGNAM="psutil"
-VERSION="3.2.2"
+VERSION="3.3.0"
HOMEPAGE="https://github.com/giampaolo/psutil"
-DOWNLOAD="https://pypi.python.org/packages/source/p/psutil/psutil-3.2.2.tar.gz"
-MD5SUM="56df1727c9e26076a80da4c3f8f67976"
+DOWNLOAD="https://pypi.python.org/packages/source/p/psutil/psutil-3.3.0.tar.gz"
+MD5SUM="0625db01ea46417308db94cc59362b65"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""