summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/Pafy/Pafy.SlackBuild86
-rw-r--r--network/Pafy/Pafy.info10
-rw-r--r--network/Pafy/README11
-rw-r--r--network/Pafy/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/network/Pafy/Pafy.SlackBuild b/network/Pafy/Pafy.SlackBuild
new file mode 100644
index 0000000000..638a81bef5
--- /dev/null
+++ b/network/Pafy/Pafy.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for Pafy
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=Pafy
+VERSION=${VERSION:-0.3.28}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/Pafy/Pafy.info b/network/Pafy/Pafy.info
new file mode 100644
index 0000000000..19d9425f37
--- /dev/null
+++ b/network/Pafy/Pafy.info
@@ -0,0 +1,10 @@
+PRGNAM="Pafy"
+VERSION="0.3.28"
+HOMEPAGE="http://np1.github.io/pafy/"
+DOWNLOAD="https://pypi.python.org/packages/source/P/Pafy/Pafy-0.3.28.tar.gz"
+MD5SUM="cd94fc23d43fb489cf26e431ce6fa4c5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/Pafy/README b/network/Pafy/README
new file mode 100644
index 0000000000..25e91a18f4
--- /dev/null
+++ b/network/Pafy/README
@@ -0,0 +1,11 @@
+Python API for YouTube - Download videos and retrieve metadata from YouTube.
+
+- Retreive metadata such as viewcount, duration, rating, author, thumbnail, etc
+- Download video or audio at requested resolution / bitrate / format / filesize
+- Command line tool (ytdl) for downloading directly from the command line
+- Retrieve the URL to stream the video in a player such as vlc or mplayer
+- Works with age-restricted videos and non-embeddable videos
+- Small, standalone, single importable module file (pafy.py)
+- Select highest quality stream for download or streaming
+- Download audio only (no video) in ogg or m4a format
+- Download video only (no audio) in m4v format
diff --git a/network/Pafy/slack-desc b/network/Pafy/slack-desc
new file mode 100644
index 0000000000..a967421598
--- /dev/null
+++ b/network/Pafy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Pafy: Pafy (Python API for YouTube content)
+Pafy:
+Pafy: Python API for YouTube - Download videos and retrieve
+Pafy: metadata from YouTube.
+Pafy:
+Pafy: Homepage: http://np1.github.io/pafy/
+Pafy:
+Pafy:
+Pafy:
+Pafy:
+Pafy: