summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/conky/README2
-rw-r--r--system/conky/conky.SlackBuild63
-rw-r--r--system/conky/conky.info12
-rw-r--r--system/conky/doinst.sh14
4 files changed, 73 insertions, 18 deletions
diff --git a/system/conky/README b/system/conky/README
index 713a22c059..0ee0f7ef2e 100644
--- a/system/conky/README
+++ b/system/conky/README
@@ -2,7 +2,7 @@ conky - A light-weight system monitor for X
Conky is a system monitor for X originally based on the torsmo code.
Since it's original conception, Conky has changed a fair bit from
-it'spredecessor. Conky can display just about anything, either on
+it's predecessor. Conky can display just about anything, either on
your root desktop or in it's own window. Conky has many built-in
objects, as well as the ability to execute programs and scripts, then
display the output from stdout.
diff --git a/system/conky/conky.SlackBuild b/system/conky/conky.SlackBuild
index 2a2d52b4fd..14938aa721 100644
--- a/system/conky/conky.SlackBuild
+++ b/system/conky/conky.SlackBuild
@@ -1,13 +1,33 @@
#!/bin/sh
# Slackware build script for conky
-# Written by eroc <eroc@linuxmail.org>
+
+# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+# 1.- Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
PRGNAM=conky
-VERSION=1.4.7
+VERSION=1.6.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -17,6 +37,8 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
set -e
@@ -25,31 +47,50 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar jxvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+rw,go-w .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ --mandir=/usr/man \
+ --enable-shared=yes \
+ --enable-static=no \
+ --enable-audacious=yes \
+ --enable-mpd=yes \
+ --enable-smapi=yes \
+ --enable-rss=yes \
+ --enable-wlan=yes \
+ --build=$ARCH-slackware-linux \
+ --host=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
-mv $PKG/usr/share/man $PKG/usr/
-gzip -9 $PKG/usr/man/man?/*
-rmdir $PKG/usr/share
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+# Don't clobber an existing config file
+mv $PKG/etc/conky/conky.conf $PKG/etc/conky/conky.conf.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-rm $PKG/usr/doc/$PRGNAM-$VERSION/{Makefile,Makefile.am,Makefile.in,conky.1}
+cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO \
+ doc/*.html extras/ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/conky/conky.info b/system/conky/conky.info
index 1141d07e17..a766fc6919 100644
--- a/system/conky/conky.info
+++ b/system/conky/conky.info
@@ -1,8 +1,8 @@
PRGNAM="conky"
-VERSION="1.4.7"
+VERSION="1.6.1"
HOMEPAGE="http://conky.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/conky/conky-1.4.7.tar.bz2"
-MD5SUM="40b929889da5f237c5f2af4a70d7f765"
-MAINTAINER="eroc"
-EMAIL="eroc@linuxmail.org"
-APPROVED="rworkman"
+DOWNLOAD="http://downloads.sourceforge.net/conky/conky-1.6.1.tar.bz2"
+MD5SUM="b2839f21cec18e5eaa338c7440a1ba28"
+MAINTAINER="Antonio Hernández Blas"
+EMAIL="hba.nihilismus@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/system/conky/doinst.sh b/system/conky/doinst.sh
new file mode 100644
index 0000000000..78304645d3
--- /dev/null
+++ b/system/conky/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD|md5sum)" = "$(cat $NEW|md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/conky/conky.conf.new