summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/sonic-visualiser/README7
-rw-r--r--audio/sonic-visualiser/sonic-visualiser.SlackBuild71
-rw-r--r--audio/sonic-visualiser/sonic-visualiser.info8
3 files changed, 22 insertions, 64 deletions
diff --git a/audio/sonic-visualiser/README b/audio/sonic-visualiser/README
index 8f935771df..83f564333c 100644
--- a/audio/sonic-visualiser/README
+++ b/audio/sonic-visualiser/README
@@ -11,9 +11,10 @@ liblo - allows remote control of sonic-visualiser via OSC.
portaudio - allows sonic-visualiser to run without a JACK or pulseaudio
server.
-Note: the SlackBuild author is unable to get sonic-visualiser 2.5 or
-3.0.1 to work with PulseAudio or PortAudio. Only jack-audio-connection-kit
-works. If you have problems with the other sound backends, try JACK.
+Note: the SlackBuild author is unable to get sonic-visualiser to work
+with PortAudio. PulseAudio seems to work but hasn't been thoroughly
+tested. If you have problems with the other audio I/O backends, try JACK.
+See File -> Preferences -> Audio I/O.
This package uses POSIX filesystem capabilities to execute with
elevated privileges (required for realtime audio processing). This
diff --git a/audio/sonic-visualiser/sonic-visualiser.SlackBuild b/audio/sonic-visualiser/sonic-visualiser.SlackBuild
index c00d915fa8..e166c6ba11 100644
--- a/audio/sonic-visualiser/sonic-visualiser.SlackBuild
+++ b/audio/sonic-visualiser/sonic-visualiser.SlackBuild
@@ -6,6 +6,16 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20181217 bkw:
+# - Update for 3.2. This was left stale for a long time due to
+# problems with SBo's old qt5, which has finally been updated,
+# thanks to dive.
+# - Get rid of static capnproto, no longer needed (thank the ghods).
+# - PulseAudio now works, update README accordingly.
+# - Yes, I'm aware that it's segfaulting on exit, but it won't dump
+# core (even though I have coredumps enabled) so I can't easily
+# diagnose it.
+
# 20170312 bkw:
# - update for 3.0.1
# - parallel build seems OK, remove -j1 (again)
@@ -38,7 +48,7 @@
# - add realtime capabilities
PRGNAM=sonic-visualiser
-VERSION=${VERSION:-3.0.1}
+VERSION=${VERSION:-3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,65 +82,14 @@ fi
set -e
rm -rf $PKG $TMP/$PRGNAM
-mkdir -p $TMP/$PRGNAM $PKG $OUTPUT
-
-# use a top-level dir under $TMP for ease of cleanup.
-cd $TMP/$PRGNAM
-
-# Grrr. Upstream requires a git version of capnproto, newer than the
-# latest release. They *really* should bundle it, or at least mention it
-# in their README or INSTALL.txt, if they're going to depend on bleeding
-# edge stuff... the only way to understand what's going on here is to
-# actually read the comments in configure.ac. We have to build a static
-# capnproto and force sonic-visualiser to use it.
-LIBVER="${LIBVER:-86ce27924ceae700a70a00963aaab3766d26b348}"
-LIBNAM=capnproto
-LIBPREFIX=$TMP/$PRGNAM/$LIBNAM
-
-rm -rf $LIBNAM-$LIBVER
-tar xvf $CWD/$LIBNAM-$LIBVER.tar.gz
-cd $LIBNAM-$LIBVER
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# following code borrowed & modified from capnproto.SlackBuild by
-# Andre Barboza:
-cd c++
- autoreconf -ivf
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=$LIBPREFIX \
- --disable-shared \
- --enable-static \
- --build=$ARCH-slackware-linux
-
- # don't run ldconfig. not needed (a) because of --disabled-shared,
- # and (b) we're installing into a non-system directory anyway.
- sed -i '/^\t*ldconfig/d' Makefile
-
- make
- make install-strip
-cd ..
-
-# These will be used by sonic-visualiser's ./configure:
-export PKG_CONFIG_PATH=$LIBPREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
-export PATH=$LIBPREFIX/bin:$PATH
-
-cd $TMP/$PRGNAM
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
QTDIR=$QT5DIR \
CFLAGS="$SLKCFLAGS" \
diff --git a/audio/sonic-visualiser/sonic-visualiser.info b/audio/sonic-visualiser/sonic-visualiser.info
index 994aef5c05..234884a7df 100644
--- a/audio/sonic-visualiser/sonic-visualiser.info
+++ b/audio/sonic-visualiser/sonic-visualiser.info
@@ -1,10 +1,8 @@
PRGNAM="sonic-visualiser"
-VERSION="3.0.1"
+VERSION="3.2"
HOMEPAGE="https://sonicvisualiser.org/"
-DOWNLOAD="https://code.soundsoftware.ac.uk/attachments/download/2213/sonic-visualiser-3.0.1.tar.gz \
- https://github.com/sandstorm-io/capnproto/archive/86ce279/capnproto-86ce27924ceae700a70a00963aaab3766d26b348.tar.gz"
-MD5SUM="78c64b91264333010f0e780cb0fd3ff7 \
- f942f43b61145dc5095ae83c14f0fff5"
+DOWNLOAD="https://code.soundsoftware.ac.uk/attachments/download/2420/sonic-visualiser-3.2.tar.gz"
+MD5SUM="215e51a307a8dfa19440fec162e3fbfc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="qt5 jack-audio-connection-kit liblrdf rubberband vamp-plugin-sdk sord"