summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/deluge/README11
-rw-r--r--network/deluge/deluge.SlackBuild22
-rw-r--r--network/deluge/deluge.info8
-rw-r--r--network/deluge/doinst.sh9
-rw-r--r--network/deluge/slack-desc2
5 files changed, 29 insertions, 23 deletions
diff --git a/network/deluge/README b/network/deluge/README
index d4d1b200db..759e112be7 100644
--- a/network/deluge/README
+++ b/network/deluge/README
@@ -1,6 +1,7 @@
-Deluge is a bittorrent client for Linux and other Unix-Like operating
-systems. Deluge was created because of the lack of a good, native, GTK
-based torrent solution for Linux.
+Deluge is a bittorrent client for Linux and other Unix-Like
+operating systems. Deluge was created because of the lack of
+a good, native, GTK based torrent solution for Linux.
-Requires boost, pyxdg and setuptools (pysetuptools)
-All available at SlackBuilds.org
+Deluge requires libboost, pyxdg, pysetuptools and
+optionaly notify-python that also can be
+found in SlackBuilds.org repository. \ No newline at end of file
diff --git a/network/deluge/deluge.SlackBuild b/network/deluge/deluge.SlackBuild
index eb1d191787..7039aa6f84 100644
--- a/network/deluge/deluge.SlackBuild
+++ b/network/deluge/deluge.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Slackware build script for deluge 1.0.2
+# Slackware build script for deluge
# Written by Stylianos Tsampas (ztsampas@otenet.gr)
#
# Redistribution and use of this script, with or without modification, is
@@ -21,7 +21,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=deluge
-VERSION=${VERSION:-1.0.2}
+VERSION=${VERSION:-1.1.0}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,11 +39,13 @@ elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -58,20 +60,22 @@ python setup.py build || exit 1
python setup.py install --root=$PKG || exit 1
-install -D -m644 deluge/data/pixmaps/deluge.svg $PKG/usr/share/pixmaps/deluge.svg
-
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE ChangeLog* README $PKG/usr/doc/$PRGNAM-$VERSION
-
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs strip -g 2> /dev/null
)
+mkdir -p $PKG/usr/man
+mv $PKG/usr/share/man/man1 $PKG/usr/man
+rm -r $PKG/usr/share/man
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE ChangeLog* README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/network/deluge/deluge.info b/network/deluge/deluge.info
index 99c447e4bc..5a817e592d 100644
--- a/network/deluge/deluge.info
+++ b/network/deluge/deluge.info
@@ -1,8 +1,8 @@
PRGNAM="deluge"
-VERSION="1.0.2"
+VERSION="1.1.0"
HOMEPAGE="http://www.deluge-torrent.org/"
-DOWNLOAD="http://download.deluge-torrent.org/source/1.0.2/deluge-1.0.2.tar.gz"
-MD5SUM="5ab62d1da88363199eaca17bd2fedaa9"
+DOWNLOAD="http://download.deluge-torrent.org/source/1.1.0/deluge-1.1.0.tar.gz"
+MD5SUM="22d8016934cc891da4e0b75949681703"
MAINTAINER="Stylianos Tsampas"
EMAIL="ztsampas@otenet.gr"
-APPROVED="David Somero"
+APPROVED="dsomero"
diff --git a/network/deluge/doinst.sh b/network/deluge/doinst.sh
index a2088524c3..9830478e8c 100644
--- a/network/deluge/doinst.sh
+++ b/network/deluge/doinst.sh
@@ -1,13 +1,14 @@
if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
-if [ -x /usr/bin/gtk-update-icon-cache ] \
- && [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
fi
diff --git a/network/deluge/slack-desc b/network/deluge/slack-desc
index 5b50989f22..3c8f7aea03 100644
--- a/network/deluge/slack-desc
+++ b/network/deluge/slack-desc
@@ -16,4 +16,4 @@ deluge: http://www.deluge-torrent.org
deluge:
deluge:
deluge:
-deluge:
+deluge: \ No newline at end of file