summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/pgsanity/README10
-rw-r--r--system/pgsanity/pgsanity.SlackBuild68
-rw-r--r--system/pgsanity/pgsanity.info10
-rw-r--r--system/pgsanity/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/system/pgsanity/README b/system/pgsanity/README
new file mode 100644
index 0000000000..1e83b1a933
--- /dev/null
+++ b/system/pgsanity/README
@@ -0,0 +1,10 @@
+PgSanity checks the syntax of PostgreSQL SQL files.
+
+It does this by leveraging the ecpg command which is traditionally used
+for preparing C files with embedded SQL for compilation. However, as
+part of that preparation, ecpg checks the embedded SQL statements for
+syntax errors using the exact same parser that is in PostgreSQL.
+
+So the approach that PgSanity takes is to take a file that has a list of
+bare SQL in it, make that file look like a C file with embedded SQL, run
+it through ecpg and let ecpg report on the syntax errors of the SQL.
diff --git a/system/pgsanity/pgsanity.SlackBuild b/system/pgsanity/pgsanity.SlackBuild
new file mode 100644
index 0000000000..7a04707c82
--- /dev/null
+++ b/system/pgsanity/pgsanity.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for pgsanity
+
+# Copyright 2014 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pgsanity
+VERSION=${VERSION:-0.2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/pgsanity/pgsanity.info b/system/pgsanity/pgsanity.info
new file mode 100644
index 0000000000..16453f80f0
--- /dev/null
+++ b/system/pgsanity/pgsanity.info
@@ -0,0 +1,10 @@
+PRGNAM="pgsanity"
+VERSION="0.2.7"
+HOMEPAGE="https://github.com/markdrago/pgsanity"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pgsanity/pgsanity-0.2.7.tar.gz"
+MD5SUM="ce57024835910dbeb13427d36ab2ef2c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools postgresql"
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
diff --git a/system/pgsanity/slack-desc b/system/pgsanity/slack-desc
new file mode 100644
index 0000000000..03a3a8adca
--- /dev/null
+++ b/system/pgsanity/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pgsanity: PgSanity (SQL syntax checker for PostgreSQL)
+pgsanity:
+pgsanity: PgSanity checks the syntax of PostgreSQL SQL files. It does this by
+pgsanity: leveraging the ecpg command which is traditionally used for preparing
+pgsanity: C files with embedded SQL for compilation. However, as part of that
+pgsanity: preparation, ecpg checks the embedded SQL statements for syntax errors
+pgsanity: using the exact same parser that is in PostgreSQL.
+pgsanity:
+pgsanity: Homepage: https://github.com/markdrago/pgsanity
+pgsanity:
+pgsanity: