summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/odoo/README15
-rw-r--r--python/odoo/odoo.SlackBuild73
-rw-r--r--python/odoo/odoo.info10
-rw-r--r--python/odoo/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/odoo/README b/python/odoo/README
new file mode 100644
index 0000000000..819fcc288d
--- /dev/null
+++ b/python/odoo/README
@@ -0,0 +1,15 @@
+Odoo is a suite of web based open source business apps.
+
+The main Odoo Apps include an Open Source CRM, Website Builder,
+eCommerce, Warehouse Management, Project Management, Billing &
+Accounting, Point of Sale, Human Resources, Marketing, Manufacturing,
+Purchase Management, ...
+
+Odoo Apps can be used as stand-alone applications, but they also
+integrate seamlessly so you get a full-featured Open Source ERP
+when you install several Apps.
+
+how-to run:
+python3 odoo-bin -r <user> -w <password>
+
+will listen by default on localhost:8069.
diff --git a/python/odoo/odoo.SlackBuild b/python/odoo/odoo.SlackBuild
new file mode 100644
index 0000000000..e08450b91d
--- /dev/null
+++ b/python/odoo/odoo.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for odoo
+
+# Copyright 2019 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=odoo
+VERSION=${VERSION:-12.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CONTRIBUTING.md COPYRIGHT LICENSE README.md SECURITY.md requirements.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/odoo/odoo.info b/python/odoo/odoo.info
new file mode 100644
index 0000000000..f68bfdc69d
--- /dev/null
+++ b/python/odoo/odoo.info
@@ -0,0 +1,10 @@
+PRGNAM="odoo"
+VERSION="12.0"
+HOMEPAGE="https://www.odoo.com"
+DOWNLOAD="https://github.com/odoo/odoo/archive/12.0/odoo-12.0.tar.gz"
+MD5SUM="c3a2d50753feb7eba2c7b6f43597229f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="postgresql nodejs psycopg2 python3-pillow passlib docutils feedparser greenlet ofxparse python3-pyparsing pyusb pyserial werkzeug python-xlrd python-chardet pytz MarkupSafe python-libsass python-webencodings lxml decorator python-requests Jinja2 python3-dateutil python-qrcode python3-babel psutil suds-jurko wkhtmltopdf num2words gevent html2text Mako PyPDF2 reportlab python-vatnumber vobject XlsxWriter python-xlwt python-ldap pydot"
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/odoo/slack-desc b/python/odoo/slack-desc
new file mode 100644
index 0000000000..8f065955e8
--- /dev/null
+++ b/python/odoo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+odoo: odoo (CRM Application)
+odoo:
+odoo: Odoo is a suite of web based open source business apps. The main
+odoo: Odoo Apps include an Open Source CRM, Website Builder, eCommerce,
+odoo: Warehouse Management, Project Management, Billing & Accounting,
+odoo: Point of Sale, Human Resources, Marketing, Manufacturing, Purchase
+odoo: Management, ...
+odoo:
+odoo: Odoo Apps can be used as stand-alone applications, but they also
+odoo: integrate seamlessly so you get a full-featured Open Source ERP
+odoo: when you install several Apps.