summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/hp2xx/README18
-rw-r--r--graphics/hp2xx/hp2xx.SlackBuild84
-rw-r--r--graphics/hp2xx/hp2xx.info10
-rw-r--r--graphics/hp2xx/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/graphics/hp2xx/README b/graphics/hp2xx/README
new file mode 100644
index 0000000000..174bbf3b63
--- /dev/null
+++ b/graphics/hp2xx/README
@@ -0,0 +1,18 @@
+hp2xx (vector graphics conversion)
+
+The hp2xx program is a versatile tool to convert vector-oriented graphics
+data given in Hewlett-Packard's HP-GL plotter language into a variety
+of popular graphics formats, both vector- and raster-oriented.
+
+The various supported output formats include Encapsulated PostScript
+(EPS), PCX, IMG, and several formats intended to facilitate the generation
+of graphics within TeX documents. In addition, hp2xx output is printable
+on the HP Laserjet/Deskjet printer series, and it may be used as a HP-GL
+previewer on many platforms.
+
+It can be used as an ImageMagick or GraphicsMagick delegate to convert
+from HPGL format.
+
+Note: hp2xx is built here without PNG output support because it's not
+compatible with modern libpng. If you need to convert HP-GL to PNG,
+use GraphicsMagick, built with hp2xx support.
diff --git a/graphics/hp2xx/hp2xx.SlackBuild b/graphics/hp2xx/hp2xx.SlackBuild
new file mode 100644
index 0000000000..8eebc71cec
--- /dev/null
+++ b/graphics/hp2xx/hp2xx.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for hp2xx
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=hp2xx
+VERSION=${VERSION:-3.4.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+mkdir -p $PKG/usr/bin $PKG/usr/info $PKG/usr/man/man1
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s,-O2 -g,$SLKCFLAGS," sources/Makefile
+
+# hp2xx hasn't been updated in over 10 years, and it's no longer
+# compatible with newer versions of libpng (because it diddles the innards
+# of the png structure, which have changed). For now, we just build without
+# PNG support. If anyone has a burning desire to fix this, please do,
+# and send me the patch.
+sed -i '/^EX_.*[pP][nN][gG]/s,^,#,' sources/Makefile
+
+# Grr.
+sed -i 's,@daveg,@@daveg,' doc/hp2xxinf.tex
+
+make prefix=/usr
+make -j1 install prefix=$PKG/usr
+
+# binary is already stripped.
+
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1 $PKG/usr/info/$PRGNAM.info
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES README TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/hp2xx/hp2xx.info b/graphics/hp2xx/hp2xx.info
new file mode 100644
index 0000000000..a0cfa58506
--- /dev/null
+++ b/graphics/hp2xx/hp2xx.info
@@ -0,0 +1,10 @@
+PRGNAM="hp2xx"
+VERSION="3.4.4"
+HOMEPAGE="https://www.gnu.org/software/hp2xx/"
+DOWNLOAD="https://ftp.gnu.org/gnu/hp2xx/hp2xx-3.4.4.tar.gz"
+MD5SUM="18808580d24b7caf2c4c7045c093329f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/graphics/hp2xx/slack-desc b/graphics/hp2xx/slack-desc
new file mode 100644
index 0000000000..ed639046d1
--- /dev/null
+++ b/graphics/hp2xx/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hp2xx: hp2xx (vector graphics conversion)
+hp2xx:
+hp2xx: The hp2xx program is a versatile tool to convert vector-oriented
+hp2xx: graphics data given in Hewlett-Packard's HP-GL plotter language into a
+hp2xx: variety of popular graphics formats, both vector- and raster-oriented.
+hp2xx:
+hp2xx: The various supported output formats include Encapsulated PostScript
+hp2xx: (EPS), PCX, IMG, and several formats intended to facilitate the
+hp2xx: generation of graphics within TeX documents. In addition, hp2xx
+hp2xx: output is printable on the HP Laserjet/Deskjet printer series,
+hp2xx: and it may be used as a HP-GL previewer on many platforms.