summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/nicotine+/README8
-rw-r--r--network/nicotine+/doinst.sh6
-rw-r--r--network/nicotine+/nicotine+.SlackBuild34
-rw-r--r--network/nicotine+/nicotine+.info8
-rw-r--r--network/nicotine+/slack-desc4
5 files changed, 30 insertions, 30 deletions
diff --git a/network/nicotine+/README b/network/nicotine+/README
index 866660dfc3..893f99ddb8 100644
--- a/network/nicotine+/README
+++ b/network/nicotine+/README
@@ -1,5 +1,5 @@
-Nicotine+ is a client for the SoulSeek filesharing network. It was "forked"
-from Nicotine, Hyriand's Soulseek client, which in turn was forked from the
-PySoulSeek project by Alexander Kanavin.
+Nicotine+ is a client for the SoulSeek filesharing network. It was
+"forked" from Nicotine, Hyriand's Soulseek client, which in turn was
+forked from the PySoulSeek project by Alexander Kanavin.
-Optional dependencies are GeoIP-Python, mutagen, sexy-python and miniupnpc.
+Optional dependencies are GeoIP-Python and miniupnpc.
diff --git a/network/nicotine+/doinst.sh b/network/nicotine+/doinst.sh
index 4e8ba7071d..4a25de5e6f 100644
--- a/network/nicotine+/doinst.sh
+++ b/network/nicotine+/doinst.sh
@@ -2,3 +2,9 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/network/nicotine+/nicotine+.SlackBuild b/network/nicotine+/nicotine+.SlackBuild
index eea88b4ed9..019efeb4fa 100644
--- a/network/nicotine+/nicotine+.SlackBuild
+++ b/network/nicotine+/nicotine+.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for nicotine+
# Copyright 2006 Iskar Enev <iskar.enev@gmail.com>
-# Copyright 2013 Audrius Kažukauskas <audrius@neutrino.lt>
+# Copyright 2013-2017 Audrius Kažukauskas <audrius@neutrino.lt>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,13 +24,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=nicotine+
-VERSION=${VERSION:-20130813_037e16c}
+SRCNAM=nicotine-plus
+VERSION=${VERSION:-1.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -46,34 +47,27 @@ set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+# Fix paths.
+sed -i 's|share/man|man|' setup.py
+sed -i "s|share/doc/nicotine|doc/$PRGNAM-$VERSION|" \
+ setup.py pynicotine/gtkgui/frame.py
-mv $PKG/usr/share/man $PKG/usr
+python setup.py install --root=$PKG
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-( cd $PKG/usr/bin ; ln -sf nicotine.py nicotine )
-
-# Let's use the larger icon to ensure proper scaling.
-sed -i 's/Icon=nicotine-plus/Icon=nicotine-plus-96px/' \
- $PKG/usr/share/applications/nicotine.desktop
-rm -f $PKG/usr/share/pixmaps/*
-cp -a files/nicotine-plus-96px.png $PKG/usr/share/pixmaps
-
-mkdir -p $PKG/usr/doc
-cp -a COPYING $PKG/usr/share/nicotine/documentation
-mv $PKG/usr/share/nicotine/documentation $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.md COPYING NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/nicotine+/nicotine+.info b/network/nicotine+/nicotine+.info
index e312fc95cf..887dec7dfd 100644
--- a/network/nicotine+/nicotine+.info
+++ b/network/nicotine+/nicotine+.info
@@ -1,10 +1,10 @@
PRGNAM="nicotine+"
-VERSION="20130813_037e16c"
+VERSION="1.4.0"
HOMEPAGE="http://nicotine-plus.org/"
-DOWNLOAD="http://neutrino.lt/download/slackware/source/nicotine+-20130813_037e16c.tar.xz"
-MD5SUM="fd5acc4fd96c8180b5b46dec6b591c3e"
+DOWNLOAD="https://github.com/Nicotine-Plus/nicotine-plus/archive/1.4.0/nicotine+-1.4.0.tar.gz"
+MD5SUM="534059b5066682fdbf4f30e7c87f89ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="mutagen"
MAINTAINER="Audrius Kažukauskas"
EMAIL="audrius@neutrino.lt"
diff --git a/network/nicotine+/slack-desc b/network/nicotine+/slack-desc
index c3bff65373..d81df9e3d4 100644
--- a/network/nicotine+/slack-desc
+++ b/network/nicotine+/slack-desc
@@ -14,6 +14,6 @@ nicotine+: things, a completely rewritten graphical user interface which
nicotine+: uses the PyGTK-2 toolkit and a less strict user request policy.
nicotine+: Nicotine+ is a fork of Hyriand's original Nicotine Soulseek client.
nicotine+:
-nicotine+: NOTE: these code changes are NOT sanctioned by Hyriand, so if this
-nicotine+: messes you up, don't bug him.
+nicotine+: Homepage: http://nicotine-plus.org/
+nicotine+:
nicotine+: