summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/jupyter-notebook/README6
-rw-r--r--development/jupyter-notebook/jupyter-notebook.SlackBuild88
-rw-r--r--development/jupyter-notebook/jupyter-notebook.info10
-rw-r--r--development/jupyter-notebook/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/development/jupyter-notebook/README b/development/jupyter-notebook/README
new file mode 100644
index 0000000000..02b8ec5480
--- /dev/null
+++ b/development/jupyter-notebook/README
@@ -0,0 +1,6 @@
+Jupyter notebook is a language-agnostic HTML notebook application for Project
+Jupyter.
+
+Jupyter kernels are needed for the notebook to be fully functional. The
+following kernels are currently available as SlackBuilds:
+* jupyter-ipykernel
diff --git a/development/jupyter-notebook/jupyter-notebook.SlackBuild b/development/jupyter-notebook/jupyter-notebook.SlackBuild
new file mode 100644
index 0000000000..2cf816d852
--- /dev/null
+++ b/development/jupyter-notebook/jupyter-notebook.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for jupyter-notebook
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=notebook
+PRGNAM=jupyter-$SRCNAM
+VERSION=${VERSION:-4.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.md README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/jupyter-notebook/jupyter-notebook.info b/development/jupyter-notebook/jupyter-notebook.info
new file mode 100644
index 0000000000..9574ad0ee2
--- /dev/null
+++ b/development/jupyter-notebook/jupyter-notebook.info
@@ -0,0 +1,10 @@
+PRGNAM="jupyter-notebook"
+VERSION="4.3.1"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://pypi.python.org/packages/d8/1f/2a79c0e0759421638287057276ce7d0f64baad5a50932da1ac963b54c9ab/notebook-4.3.1.tar.gz"
+MD5SUM="70cc97ad19c0f9246ad295a653475e2a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="Jinja2 jupyter_client jupyter-nbformat singledispatch tornado"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/jupyter-notebook/slack-desc b/development/jupyter-notebook/slack-desc
new file mode 100644
index 0000000000..7f4b6fdbaa
--- /dev/null
+++ b/development/jupyter-notebook/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jupyter-notebook: jupyter-notebook (Jupyter interactive notebook)
+jupyter-notebook:
+jupyter-notebook: Jupyter notebook is a language-agnostic HTML notebook application for
+jupyter-notebook: Project Jupyter.
+jupyter-notebook:
+jupyter-notebook:
+jupyter-notebook:
+jupyter-notebook:
+jupyter-notebook:
+jupyter-notebook:
+jupyter-notebook: