summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/JDSP4Linux/JDSP4Linux.SlackBuild120
-rw-r--r--audio/JDSP4Linux/JDSP4Linux.info10
-rw-r--r--audio/JDSP4Linux/README1
-rw-r--r--audio/JDSP4Linux/README.md343
-rw-r--r--audio/JDSP4Linux/doinst.sh3
-rw-r--r--audio/JDSP4Linux/slack-desc19
6 files changed, 496 insertions, 0 deletions
diff --git a/audio/JDSP4Linux/JDSP4Linux.SlackBuild b/audio/JDSP4Linux/JDSP4Linux.SlackBuild
new file mode 100644
index 0000000000..aaee343bb6
--- /dev/null
+++ b/audio/JDSP4Linux/JDSP4Linux.SlackBuild
@@ -0,0 +1,120 @@
+#!/bin/bash
+
+# Slackware build script for JamesDSP for Linux v2.3
+
+# Copyright 2022 Ralph Spitzner <rasp@spitzner.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=JDSP4Linux
+VERSION=${VERSION:-2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+mkdir build
+cd build
+qmake-qt5 ../JDSP4Linux.pro
+make
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/share/applications/
+mkdir -p $PKG/usr/bin
+cp src/jamesdsp $PKG/usr/bin
+
+cat <<EOT >> $PKG/usr/share/applications/jamesdsp.desktop
+[Desktop Entry]
+Name=JamesDSP
+GenericName=Audio effect processor
+Comment=JamesDSP for Linux
+Keywords=equalizer;audio;effect
+Categories=AudioVideo;Audio;
+Exec=jamesdsp
+Icon=/usr/share/pixmaps/jamesdsp.png
+StartupNotify=false
+Terminal=false
+Type=Application
+EOT
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
+
diff --git a/audio/JDSP4Linux/JDSP4Linux.info b/audio/JDSP4Linux/JDSP4Linux.info
new file mode 100644
index 0000000000..fc49bf40a5
--- /dev/null
+++ b/audio/JDSP4Linux/JDSP4Linux.info
@@ -0,0 +1,10 @@
+PRGNAM="JDSP4Linux"
+VERSION="2.3"
+HOMEPAGE="https://github.com/Audio4Linux/JDSP4Linux"
+DOWNLOAD="https://github.com/raspo666/miscfiles/raw/main/JDSP4Linux-2.3.tar.xz"
+MD5SUM="f08e365ceca81c419503594bb2fd7dde"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ralph Spitzner"
+EMAIL="rasp@spitzner.org"
diff --git a/audio/JDSP4Linux/README b/audio/JDSP4Linux/README
new file mode 100644
index 0000000000..cb4c5466fd
--- /dev/null
+++ b/audio/JDSP4Linux/README
@@ -0,0 +1 @@
+Open-source sound effects for PipeWire and PulseAudio
diff --git a/audio/JDSP4Linux/README.md b/audio/JDSP4Linux/README.md
new file mode 100644
index 0000000000..03729f5d14
--- /dev/null
+++ b/audio/JDSP4Linux/README.md
@@ -0,0 +1,343 @@
+<h1 align="center">
+ <img alt="Icon" width="75" src="https://github.com/Audio4Linux/JDSP4Linux/blob/master/resources/icons/icon.png?raw=true">
+ <br>
+ JamesDSP for Linux
+ <br>
+</h1>
+<h4 align="center">Open-source sound effects for PipeWire and PulseAudio</h4>
+<p align="center">
+ <a href="https://github.com/Audio4Linux/JDSP4Linux/releases">
+ <img alt="GitHub release (latest by date)" src="https://img.shields.io/github/v/release/Audio4Linux/JDSP4Linux">
+ </a>
+ <a href="https://github.com/Audio4Linux/JDSP4Linux/blob/master/LICENSE">
+ <img alt="License" src="https://img.shields.io/github/license/Audio4Linux/JDSP4Linux">
+ </a>
+ <a href="https://github.com/Audio4Linux/JDSP4Linux/">
+ <img alt="Windows build" src="https://img.shields.io/github/repo-size/Audio4Linux/JDSP4Linux">
+ </a>
+</p>
+<p align="center">
+ <a href="#features">Features</a> •
+ <a href="#installation">Installation</a> •
+ <a href="#contributors">Contributors</a> •
+ <a href="#license">License</a>
+</p>
+
+<p align="center">
+ <img alt="Screenshot" width="702" src="https://github.com/Audio4Linux/JDSP4Linux/blob/master/meta/screenshot.png?raw=true">
+</p>
+
+<p align="center">
+Linux port developed by <a href="https://github.com/thepbone">@thepbone</a> (<a href="https://t.me/thepbone">Telegram</a>)
+<p/><p align="center">
+<a href="https://github.com/james34602/JamesDSPManager">JamesDSP</a> was initially published as an audio effects processor<br>for Android devices and is written by <a href="https://github.com/james34602">James Fung (@james34602)</a>.
+</p>
+<p align="center">
+ Feel free to join our <a href="https://t.me/joinchat/FTKC2A2bolHkFAyO-fuPjw">Telegram group</a> for support and updates
+</p>
+
+## Features
+
+* Automatic bass boost
+ * Frequency-detecting bass-boost. Automatically sets its own parameters, such as gain, bandwidth, and cut-off frequency, by analyzing the incoming audio stream
+* Automatic dynamic range compressor
+ * A highly automated multiband dynamic range adjusting effect
+* Complex reverberation IIR network (Progenitor 2)
+* Interpolated FIR equalizer with flexible bands
+* Arbitrary response equalizer (also known as GraphicEQ from EqualizerAPO)
+ * AutoEQ database integration (requires network connection)
+* Partitioned convolver (Auto segmenting convolution)
+ * Supports mono, stereo, full/true stereo (LL, LR, RL, RR) impulse response
+* Crossfeed
+ * Realistic surround effects
+* Soundstage wideness
+ * A multiband stereo wideness controller
+* ViPER-DDC
+ * Perform parametric equalization on audio
+ * Create VDC input files using [thepbone/DDCToolbox](https://github.com/thepbone/DDCToolbox)
+* Analog modeling
+ * An aliasing-free even harmonic generator
+* Output limiter
+* **Scripting engine: Live programmable DSP**
+ * Write your own audio effects using the [EEL2 scripting language](https://github.com/james34602/EEL_CLI)
+ * Auto-generate a basic user interface for your script to modify specific parameters/constants without editing the actual code
+ * The scripting language has been extended using many DSP-related functions for easy access, for example, spectral processing, constant Q transform, multi-purpose FIR filter designer IIR sub-bands transformation, etc...
+ * **This app also includes a custom minimal scripting IDE**:
+ * Syntax highlighting
+ * Basic code completion
+ * Dynamic code outline window
+ * Console output support
+ * Detailed error messages with inline code highlighting
+
+
+## PipeWire vs PulseAudio
+
+**Designed for use with PipeWire. PulseAudio is only supported for backward compatibility.**
+
+PipeWire has a much lower latency compared to PulseAudio when injecting audio effects processors into the audio graph. Unfortunately, PipeWire is not yet completely stable and does not work correctly on virtual machines. If you cannot get any audio output when using PipeWire, consider switching to PulseAudio until proper hardware support is available.
+
+I'm currently not planning to add more advanced support for Pulseaudio clients. Features such as selective app exclusion, changing the target audio device, and similar features will only be available to PipeWire clients.
+
+*Important: This application can be either compiled with PulseAudio or PipeWire support. Please make sure you choose the correct flavor for your Linux setup before installing!*
+
+*Note: PipeWire's compatibility mode for PulseAudio apps does not work with the PulseAudio flavor of this app. Use the version for PipeWire instead.*
+
+### Which one am I using?
+
+Follow the instructions below if you don't know which one your Linux distribution is using. If you already know, skip to the 'Install dependencies' section.
+
+##### Step 1: Is PipeWire installed and active?
+
+Run `pw-cli dump short core` in your terminal.
+
+Does the terminal output look similar to the pattern below after executing the command?
+
+```
+0: u="USER" h="HOSTNAME" v="0.3.35" n="pipewire-0"
+```
+
+* **YES**: You're using PipeWire. Skip ahead, and follow the instructions to install JamesDSP with PipeWire support.
+
+* **NO**: If the command `pw-cli` is not found or it returned an error, you're probably not using PipeWire. Continue to step 2 to find out if PulseAudio is available on your system.
+
+##### Step 2: Is PulseAudio installed and active?
+
+Run `LC_ALL=C pactl info | grep "Server Name:"` in your terminal.
+
+Does the terminal output look like this after executing the command?
+
+```
+Server Name: pulseaudio
+```
+
+* **YES**: You're using PulseAudio. Skip ahead, and follow the instructions to install JamesDSP with PulseAudio support.
+
+* **NO**: If the command `pactl` is not found or it returned an error, either your PA installation is broken or you are using another audio framework like Jack. Consider switching to PipeWire in this case.
+
+**IMPORTANT:** If the output mentions PipeWire (`Server Name: PulseAudio (on PipeWire 0.3.35)`), you are using PulseAudio via PipeWire's compatibility mode. You need to install JamesDSP with PipeWire support in this case!
+
+## Installation
+
+**Decide whether you need to install the PipeWire or PulseAudio version of this app!**
+
+If you don't know which version fits your Linux setup, go to the [PipeWire vs PulseAudio section](#which-one-am-i-using) above.
+
+* [Debian/Ubuntu (PPA)](#debianubuntu)
+* [Arch Linux (AUR)](#arch)
+* [Fedora/openSUSE](#fedoraopensuse)
+* [Build from sources](#build-from-sources)
+
+### Debian/Ubuntu
+
+Minimum system requirements:
+* Distro based on Debian 11 or later **OR**
+* Distro based on Ubuntu 20.04 or later
+
+Add PPA Repo
+```bash
+sudo apt install -y curl
+curl -s --compressed "https://thepbone.github.io/PPA-Repository/KEY.gpg" | sudo apt-key add -
+sudo curl -s --compressed -o /etc/apt/sources.list.d/thepbone_ppa.list "https://thepbone.github.io/PPA-Repository/thepbone_ppa.list"
+sudo apt update
+```
+Install from PPA
+
+For **PipeWire clients** only:
+```bash
+sudo apt install jamesdsp-pipewire
+```
+For **PulseAudio clients** only:
+```bash
+sudo apt install jamesdsp-pulse
+```
+[View PPA on GitHub](https://github.com/ThePBone/PPA-Repository)
+
+
+### Arch
+[AUR packages](https://aur.archlinux.org/packages/?O=0&K=jamesdsp) are available:
+
+For **PipeWire clients** only:
+* Stable version
+
+ ![AUR version](https://img.shields.io/aur/version/jamesdsp) ![AUR version](https://img.shields.io/aur/votes/jamesdsp) ![AUR version](https://img.shields.io/aur/maintainer/jamesdsp) ![AUR version](https://img.shields.io/aur/last-modified/jamesdsp)
+ ```
+ yay -S jamesdsp
+ ```
+
+* Development version
+
+ ![AUR version](https://img.shields.io/aur/version/jamesdsp-git) ![AUR version](https://img.shields.io/aur/votes/jamesdsp-git) ![AUR version](https://img.shields.io/aur/maintainer/jamesdsp-git) ![AUR version](https://img.shields.io/aur/last-modified/jamesdsp-git)
+ ```
+ yay -S jamesdsp-git
+ ```
+
+For **PulseAudio clients** only:
+* Stable version
+
+ ![AUR version](https://img.shields.io/aur/version/jamesdsp-pulse) ![AUR version](https://img.shields.io/aur/votes/jamesdsp-pulse) ![AUR version](https://img.shields.io/aur/maintainer/jamesdsp-pulse) ![AUR version](https://img.shields.io/aur/last-modified/jamesdsp-pulse)
+ ```
+ yay -S jamesdsp-pulse
+ ```
+
+* Development version
+
+ ![AUR version](https://img.shields.io/aur/version/jamesdsp-pulse-git) ![AUR version](https://img.shields.io/aur/votes/jamesdsp-pulse-git) ![AUR version](https://img.shields.io/aur/maintainer/jamesdsp-pulse-git) ![AUR version](https://img.shields.io/aur/last-modified/jamesdsp-pulse-git)
+ ```
+ yay -S jamesdsp-pulse-git
+ ```
+
+### Fedora/openSUSE
+
+Package maintained by [@theAeon](https://github.com/theAeon) on [Fedora COPR](https://copr.fedorainfracloud.org/coprs/arrobbins/JDSP4Linux/).
+Built for Fedora 34/35/Rawhide and OpenSUSE Tumbleweed.
+
+For **PipeWire clients** only:
+```
+yum copr enable arrobbins/JDSP4Linux && yum update && yum install jamesdsp
+```
+
+If you are still using PulseAudio with your Fedora/openSUSE installation, refer to the '[Build from sources](#build-from-sources)' section below instead.
+
+### Build from sources
+
+#### Install dependencies
+
+*NOTE:* Only execute the line that applies to your system configuration. If your distro is not included here, you need to research which packages to install by yourself.
+
+**Debian/Ubuntu-based distros**
+
+Debian/Ubuntu + **PipeWire** clients only:
+
+```bash
+sudo apt install build-essential libarchive-dev qtbase5-private-dev qtbase5-dev libqt5svg5-dev libglibmm-2.4-dev libglib2.0-dev libpipewire-0.3-dev
+```
+NOTE: Pipewire version 0.3 or later required. Unfortunately, this version is only in the official Ubuntu repository for Ubuntu 20.10 or later. If you use Ubuntu 20.04 or earlier, you need to compile this dependency yourself or use PulseAudio instead.
+
+Debian/Ubuntu + **PulseAudio** clients only:
+
+```bash
+sudo apt install build-essential libarchive-dev qtbase5-private-dev qtbase5-dev libqt5svg5-dev libglibmm-2.4-dev libglib2.0-dev libpulse-dev libgstreamer1.0-dev libgstreamer-plugins-good1.0-dev
+```
+**Fedora**
+
+Fedora 34 + **PipeWire** clients only:
+
+```bash
+sudo dnf install libarchive-devel qt5-qtbase-devel qt5-qtbase-private-devel qt5-qtsvg-devel glibmm24-devel glib2-devel pipewire-devel
+```
+Fedora 34 + **PulseAudio** clients only:
+
+```bash
+sudo dnf install libarchive-devel qt5-qtbase-devel qt5-qtbase-private-devel qt5-qtsvg-devel glibmm24-devel glib2-devel pulseaudio-libs-devel gstreamer1-devel gstreamer1-plugins-good-devel
+```
+**Arch Linux**
+
+Arch Linux + **PipeWire** clients only:
+
+```bash
+sudo pacman -S libarchive qt5-base qt5-svg glib2 glibmm pipewire
+```
+
+Arch Linux + **PulseAudio** clients only:
+
+```
+sudo pacman -S libarchive qt5-base qt5-svg glib2 glibmm libpulse gst-plugins-good gstreamer
+```
+
+#### Build application
+
+Clone git repositories and submodules:
+
+```bash
+git clone --recursive https://github.com/Audio4Linux/JDSP4Linux
+```
+
+Prepare build environment
+
+```bash
+cd JDSP4Linux
+mkdir build
+cd build
+```
+
+Compile application - **PipeWire** clients only:
+
+```bash
+qmake ../JDSP4Linux.pro
+make
+```
+Compile application - **PulseAudio** clients only:
+
+```bash
+qmake ../JDSP4Linux.pro "CONFIG += USE_PULSEAUDIO"
+make
+```
+
+Execute compiled binary
+
+```bash
+./src/jamesdsp
+```
+
+#### Optional: Manual installation + menu entry
+
+Copy binary to /usr/local/bin and set permissions
+
+```bash
+sudo cp src/jamesdsp /usr/local/bin
+sudo chmod 755 /usr/local/bin/jamesdsp
+```
+
+Create a menu entry
+
+```bash
+sudo cat <<EOT >> /usr/share/applications/jamesdsp.desktop
+[Desktop Entry]
+Name=JamesDSP
+GenericName=Audio effect processor
+Comment=JamesDSP for Linux
+Keywords=equalizer;audio;effect
+Categories=AudioVideo;Audio;
+Exec=jamesdsp
+Icon=/usr/share/pixmaps/jamesdsp.png
+StartupNotify=false
+Terminal=false
+Type=Application
+EOT
+```
+
+Download icon
+
+```bash
+sudo wget -O /usr/share/pixmaps/jamesdsp.png https://raw.githubusercontent.com/Audio4Linux/JDSP4Linux-GUI/master/resources/icons/icon.png -q --show-progress
+```
+
+## Screenshots
+
+<p align="center">
+ <img alt="Screenshot" width="702" src="https://github.com/Audio4Linux/JDSP4Linux/blob/master/meta/screenshot_presets.png?raw=true">
+ <img alt="Screenshot" width="702" src="https://github.com/Audio4Linux/JDSP4Linux/blob/master/meta/screenshot_eel.png?raw=true">
+ <img alt="Screenshot" width="702" src="https://github.com/Audio4Linux/JDSP4Linux/blob/master/meta/screenshot_graphiceq.png?raw=true">
+ <img alt="Screenshot" width="702" src="https://github.com/Audio4Linux/JDSP4Linux/blob/master/meta/screenshot_ide.png?raw=true">
+</p>
+
+## Contributors
+
+* [James Fung](https://github.com/james34602) - Developer of the core library ['libjamesdsp'](https://github.com/james34602/JamesDSPManager/tree/master/Main)
+* [yochananmarqos](https://github.com/yochananmarqos) - AUR packages
+* [theAeon](https://github.com/theAeon) - RPM packages
+
+##### Other credits
+* PipeWire implementation based on [EasyEffects](https://github.com/wwmm/EasyEffects)
+
+## License
+
+This project is licensed under [GPLv3](LICENSE).
+
+```
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
+INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR
+THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+```
diff --git a/audio/JDSP4Linux/doinst.sh b/audio/JDSP4Linux/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/audio/JDSP4Linux/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/audio/JDSP4Linux/slack-desc b/audio/JDSP4Linux/slack-desc
new file mode 100644
index 0000000000..4c6d7bdd38
--- /dev/null
+++ b/audio/JDSP4Linux/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+JDSP4Linux: JDSP4Linux (Pipewire system equalizer)
+JDSP4Linux:
+JDSP4Linux: Open-source sound effects for PipeWire and PulseAudio
+JDSP4Linux:
+JDSP4Linux:
+JDSP4Linux:
+JDSP4Linux:
+JDSP4Linux:
+JDSP4Linux: Homepage: https://github.com/Audio4Linux/JDSP4Linux
+JDSP4Linux:
+JDSP4Linux: