summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--academic/FreeFem/FreeFem.SlackBuild19
-rw-r--r--academic/FreeFem/FreeFem.info8
2 files changed, 16 insertions, 11 deletions
diff --git a/academic/FreeFem/FreeFem.SlackBuild b/academic/FreeFem/FreeFem.SlackBuild
index 30ca0bf8dd..35ce05e04b 100644
--- a/academic/FreeFem/FreeFem.SlackBuild
+++ b/academic/FreeFem/FreeFem.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for FreeFem
# Based on the Slackware 14.2 SlackBuild and on PKGBUILD script for freefem from AUR
#
-# Copyright 2019-2020, Fellype do Nascimento, Campinas - Brazil
+# Copyright 2019-2022, Fellype do Nascimento, Campinas - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,11 +26,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=FreeFem
-VERSION=${VERSION:-4.5}
+VERSION=${VERSION:-4.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCVER=${SRCVER:-4.5} # Variable used in some versions that are numbered as x.y-z
+SRCVER=${SRCVER:-4.11}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -55,12 +52,15 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
SPEC=""
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
SPEC=""
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
SPEC="-spec linux-g++-64"
+ LIBDIRSUFFIX="64"
fi
@@ -87,6 +87,7 @@ autoreconf -i
--prefix=/usr \
--sysconfdir=/etc \
--disable-mumps \
+ --with-petsc=/usr/lib${LIBDIRSUFFIX}/petsc/conf/petscvariables \
--with-mpi=/usr/bin/mpic++ \
--enable-hpddm \
--enable-opengl
@@ -99,7 +100,11 @@ find . -name Makefile -exec sed -i 's+^dir+dir =+' {} \;
make
make install DESTDIR=$PKG
-find "$PKG"/usr/lib/ff++/ -name "*.h" -exec chmod o+r {} \;
+if [ "$ARCH" = "x86_64" ]; then
+ mv $PKG/usr/lib $PKG/usr/lib${LIBDIRSUFFIX}
+fi
+
+find "$PKG"/usr/lib${LIBDIRSUFFIX}/ff++/ -name "*.h" -exec chmod o+r {} \;
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/academic/FreeFem/FreeFem.info b/academic/FreeFem/FreeFem.info
index c61fc4c006..990f463359 100644
--- a/academic/FreeFem/FreeFem.info
+++ b/academic/FreeFem/FreeFem.info
@@ -1,14 +1,14 @@
PRGNAM="FreeFem"
-VERSION="4.5"
+VERSION="4.11"
HOMEPAGE="https://freefem.org/"
-DOWNLOAD="https://github.com/FreeFem/FreeFem-sources/archive/v4.5/FreeFem-sources-4.5.tar.gz \
+DOWNLOAD="https://github.com/FreeFem/FreeFem-sources/archive/v4.11/FreeFem-sources-4.11.tar.gz \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/metis-5.1.0.tar.gz \
http://www.tetgen.org/1.5/src/tetgen1.5.1-beta1.tar.gz"
-MD5SUM="4df8fe1c1bc2c042df1f74371e846748 \
+MD5SUM="b6355b01842204d068ce4530dd45b32f \
5465e67079419a69e0116de24fce58fe \
3d55c197bcbfc611b7ced6f343643756"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="arpack-ng hdf5 openmpi suitesparse"
+REQUIRES="arpack-ng hdf5 suitesparse petsc"
MAINTAINER="Fellype do Nascimento"
EMAIL="fellype (at) gmail (dot) com"