summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/pycdio/pycdio.SlackBuild10
-rw-r--r--python/pycdio/pycdio.info2
2 files changed, 5 insertions, 7 deletions
diff --git a/python/pycdio/pycdio.SlackBuild b/python/pycdio/pycdio.SlackBuild
index 50bbd1f4e8..d270b73ef4 100644
--- a/python/pycdio/pycdio.SlackBuild
+++ b/python/pycdio/pycdio.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pycdio
# Copyright 2015 Dugan Chen Canada
-# Copyright 2020, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2020-2022, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,13 +77,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a example/ AUTHORS COPYING ChangeLog NEWS.md README.rst THANKS \
+cp -a example/ AUTHORS ChangeLog NEWS.md README.rst THANKS \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/pycdio/pycdio.info b/python/pycdio/pycdio.info
index cdad5c228d..28319ef810 100644
--- a/python/pycdio/pycdio.info
+++ b/python/pycdio/pycdio.info
@@ -1,7 +1,7 @@
PRGNAM="pycdio"
VERSION="2.1.0"
HOMEPAGE="https://www.gnu.org/software/libcdio/"
-DOWNLOAD="https://files.pythonhosted.org/packages/7f/45/719236c06ef0aebe693d1b18e8ed6c08afe8caa95a2fa0f2c2172e6b6807/pycdio-2.1.0.tar.gz"
+DOWNLOAD="https://ftp.gnu.org/gnu/libcdio/pycdio-2.1.0.tar.gz"
MD5SUM="d1adcee07dc0f510a983547bf5046632"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""