summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/dfvfs/dfvfs.SlackBuild10
-rw-r--r--python/dfvfs/dfvfs.info8
2 files changed, 9 insertions, 9 deletions
diff --git a/python/dfvfs/dfvfs.SlackBuild b/python/dfvfs/dfvfs.SlackBuild
index 81a953c2a1..cd8c4249da 100644
--- a/python/dfvfs/dfvfs.SlackBuild
+++ b/python/dfvfs/dfvfs.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for dfvfs
-# Copyright 2014-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2014-2022 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# updated for v20190128, March 2019
+# updated for v20220419 May 2022
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dfvfs
-VERSION=${VERSION:-20190128}
+VERSION=${VERSION:-20220419}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,13 +80,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKNOWLEDGEMENTS AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
# Remove duplicated docs in /usr/share/doc
rm -rf $PKG/usr/share
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/dfvfs/dfvfs.info b/python/dfvfs/dfvfs.info
index dcdafb1172..8eabdf5286 100644
--- a/python/dfvfs/dfvfs.info
+++ b/python/dfvfs/dfvfs.info
@@ -1,10 +1,10 @@
PRGNAM="dfvfs"
-VERSION="20190128"
+VERSION="20220419"
HOMEPAGE="https://github.com/log2timeline/dfvfs"
-DOWNLOAD="https://slackware.uk/sbosrcarch/by-md5/b/4/b40edc047cea330be013921d575f8caa/dfvfs-20190128.tar.gz"
-MD5SUM="b40edc047cea330be013921d575f8caa"
+DOWNLOAD="https://linuxleo.com/Source/dfvfs-20220419.tar.gz"
+MD5SUM="1c68c744d186b7c04c6c4d2deae5e9a0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-pycrypto dfdatetime dtfabric libbde libewf libfsapfs libfsntfs libfvde libfwnt libqcow libsigscan libsmdev libsmraw pytsk libvhdi libvmdk libvshadow libvslvm pysqlite backports.lzma"
+REQUIRES="cryptography dfdatetime dtfabric libbde libewf libfsapfs libfsext libfshfs libfsntfs libfsxfs libfvde libfwnt libluksde libmodi libphdi libqcow libsigscan libsmdev libsmraw pytsk libvhdi libvmdk libvsgpt libvshadow libvslvm xattr"
MAINTAINER="Barry J. Grundy"
EMAIL="bgrundy<at>linuxleo.com"