summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/backintime/README13
-rw-r--r--system/backintime/backintime.SlackBuild97
-rw-r--r--system/backintime/backintime.info10
-rw-r--r--system/backintime/doinst.sh8
-rw-r--r--system/backintime/slack-desc19
5 files changed, 0 insertions, 147 deletions
diff --git a/system/backintime/README b/system/backintime/README
deleted file mode 100644
index 9e0a7503f6..0000000000
--- a/system/backintime/README
+++ /dev/null
@@ -1,13 +0,0 @@
-Back In Time is a simple backup tool for Linux inspired from "flyback
-project" and "TimeVault". The backup is done by taking snapshots of a
-specified set of directories.
-
-All you have to do is configure:
-
- * Where to save snapshot
- * What directories to backup
- * When backup should be done (manual, every hour, every day,
- every week, every month)
-
-Launch the GUI with backintime-kde4 or from the system menu.
-
diff --git a/system/backintime/backintime.SlackBuild b/system/backintime/backintime.SlackBuild
deleted file mode 100644
index de59bf2973..0000000000
--- a/system/backintime/backintime.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/sh
-
-# SlackBuild script for Back In Time.
-#
-# Copyright 2010-2011 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=backintime
-VERSION=1.0.8
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-${VERSION}_src.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Common components
-cd $TMP/$PRGNAM-$VERSION/common
- ./configure
- # Fix documentation paths
- sed -i 's|/share/doc/backintime-common|/doc/'$PRGNAM'-'$VERSION'|g' \
- $TMP/$PRGNAM-$VERSION/common/Makefile
- make
- make install DESTDIR=$PKG
-cd -
-
-# KDE4 components
-cd $TMP/$PRGNAM-$VERSION/kde4
- ./configure
- # Fix documentation paths
- sed -i 's|/share/doc/backintime-kde4|/doc/'$PRGNAM'-'$VERSION'|g' \
- $TMP/$PRGNAM-$VERSION/kde4/Makefile
- make
- make install DESTDIR=$PKG
-cd -
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Move the manpages from /usr/share to /usr
-mv $PKG/usr/share/man/ $PKG/usr
-
-# Move the KDE4 docbook files to the appropriate directory
-mv $PKG/usr/share/doc/kde4/HTML $PKG/usr/doc/
-
-# Remove duplicate documentation in /usr/share/doc/
-rm -r $PKG/usr/share/doc
-
-cp -a \
- AUTHORS CHANGES LICENSE README TODO TRANSLATIONS VERSION \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/backintime/backintime.info b/system/backintime/backintime.info
deleted file mode 100644
index d29766f8f9..0000000000
--- a/system/backintime/backintime.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="backintime"
-VERSION="1.0.8"
-HOMEPAGE="http://backintime.le-web.org/"
-DOWNLOAD="http://backintime.le-web.org/download/backintime/backintime-1.0.8_src.tar.gz"
-MD5SUM="676c743cb64fdc646c290c62e45640ff"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Pierre Cazenave"
-EMAIL="pwcazenave <at> gmail {dot} com"
diff --git a/system/backintime/doinst.sh b/system/backintime/doinst.sh
deleted file mode 100644
index e4e6459838..0000000000
--- a/system/backintime/doinst.sh
+++ /dev/null
@@ -1,8 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
diff --git a/system/backintime/slack-desc b/system/backintime/slack-desc
deleted file mode 100644
index 46fc8218d7..0000000000
--- a/system/backintime/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-backintime: backintime (simple backup tool)
-backintime:
-backintime: Back In Time is a simple backup tool for Linux inspired from
-backintime: "flyback project" and "TimeVault". The backup is done by taking
-backintime: snapshots of a specified set of directories.
-backintime:
-backintime: All you have to do is configure where to save snapshot, what
-backintime: directories to backup and when backup should be done (manual,
-backintime: every hour, every day, every week, every month)
-backintime:
-backintime: http://backintime.le-web.org/