summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--academic/bpp1.9-seq/README10
-rw-r--r--academic/bpp1.9-seq/bpp1.9-seq.SlackBuild116
-rw-r--r--academic/bpp1.9-seq/bpp1.9-seq.info10
-rw-r--r--academic/bpp1.9-seq/slack-desc19
4 files changed, 155 insertions, 0 deletions
diff --git a/academic/bpp1.9-seq/README b/academic/bpp1.9-seq/README
new file mode 100644
index 0000000000..eaeb91d929
--- /dev/null
+++ b/academic/bpp1.9-seq/README
@@ -0,0 +1,10 @@
+Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+analysis, phylogenetics, molecular evolution and population genetics.
+Bio++ is Object Oriented and is designed to be both easy to use and
+computer efficient. Bio++ intends to help programmers to write
+computer expensive programs, by providing them a set of re-usable
+tools.
+
+This contains the Bio++ 1.9 (April 2010) Seq Library. It can be
+installed along the current Bio++ suite libraries, however they better
+not be present at compile time.
diff --git a/academic/bpp1.9-seq/bpp1.9-seq.SlackBuild b/academic/bpp1.9-seq/bpp1.9-seq.SlackBuild
new file mode 100644
index 0000000000..fcea3aef1d
--- /dev/null
+++ b/academic/bpp1.9-seq/bpp1.9-seq.SlackBuild
@@ -0,0 +1,116 @@
+#!/bin/bash
+
+# Slackware build script for bpp1.9-seq
+
+# Copyright 2020-2022 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=bpp1.9-seq
+SRCNAM=bpp-seq
+VERSION=${VERSION:-1.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+LIBDIRPATH="-Wl,-rpath,/usr/lib${LIBDIRSUFFIX}/Bpp1.9"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Use custom install place, so libs can coexist with latest bpp
+export PATH="/usr/lib${LIBDIRSUFFIX}/Bpp1.9/:$PATH"
+sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Seq.spec
+
+source /etc/profile.d/gcc5.sh
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS $LIBDIRPATH" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Seq/cmake_install.cmake
+ sed -i "s:/lib\b:/lib${LIBDIRSUFFIX}/Bpp1.9:g" Seq/cmake_install.cmake
+
+ make
+ make DESTDIR=$PKG install
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+chmod 0644 AUTHORS ChangeLog COPYING
+cp -a \
+ AUTHORS ChangeLog COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/bpp1.9-seq/bpp1.9-seq.info b/academic/bpp1.9-seq/bpp1.9-seq.info
new file mode 100644
index 0000000000..0d6d9f38df
--- /dev/null
+++ b/academic/bpp1.9-seq/bpp1.9-seq.info
@@ -0,0 +1,10 @@
+PRGNAM="bpp1.9-seq"
+VERSION="1.7.0"
+HOMEPAGE="http://biopp.univ-montp2.fr/"
+DOWNLOAD="https://raw.githubusercontent.com/slackalaxy/sources/main/bpp-seq-1.7.0.tar.gz"
+MD5SUM="4256293637ac4131c0d030f5265b8b8b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="bpp1.9-numcalc"
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"
diff --git a/academic/bpp1.9-seq/slack-desc b/academic/bpp1.9-seq/slack-desc
new file mode 100644
index 0000000000..bd154ce1f1
--- /dev/null
+++ b/academic/bpp1.9-seq/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bpp1.9-seq: bpp1.9-seq (Bio++ 1.9 Seq Library)
+bpp1.9-seq:
+bpp1.9-seq: Contains the Bio++ 1.9 Seq Library.
+bpp1.9-seq:
+bpp1.9-seq:
+bpp1.9-seq:
+bpp1.9-seq:
+bpp1.9-seq:
+bpp1.9-seq:
+bpp1.9-seq:
+bpp1.9-seq: