summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/jupyter-ipykernel/README1
-rw-r--r--development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild88
-rw-r--r--development/jupyter-ipykernel/jupyter-ipykernel.info10
-rw-r--r--development/jupyter-ipykernel/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/development/jupyter-ipykernel/README b/development/jupyter-ipykernel/README
new file mode 100644
index 0000000000..f0974bc59f
--- /dev/null
+++ b/development/jupyter-ipykernel/README
@@ -0,0 +1 @@
+IPython Kernel for Jupyter.
diff --git a/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild b/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild
new file mode 100644
index 0000000000..e5842c34b0
--- /dev/null
+++ b/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for jupyter-ipykernel
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=ipykernel
+PRGNAM=jupyter-$SRCNAM
+VERSION=${VERSION:-4.5.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.md README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/jupyter-ipykernel/jupyter-ipykernel.info b/development/jupyter-ipykernel/jupyter-ipykernel.info
new file mode 100644
index 0000000000..a4fa261dd5
--- /dev/null
+++ b/development/jupyter-ipykernel/jupyter-ipykernel.info
@@ -0,0 +1,10 @@
+PRGNAM="jupyter-ipykernel"
+VERSION="4.5.2"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://pypi.python.org/packages/2d/1b/eee47b5cd8b2fcdde587cad1e8d3f7eae7bdfa1d36a94ad316fc5fbee833/ipykernel-4.5.2.tar.gz"
+MD5SUM="4048987076b85814202cd29b1dd3fc7b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ipython jupyter-notebook"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/jupyter-ipykernel/slack-desc b/development/jupyter-ipykernel/slack-desc
new file mode 100644
index 0000000000..df185b168e
--- /dev/null
+++ b/development/jupyter-ipykernel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jupyter-ipykernel: jupyter-ipykernel (IPython Kernel for Jupyter)
+jupyter-ipykernel:
+jupyter-ipykernel: IPython Kernel for Jupyter.
+jupyter-ipykernel:
+jupyter-ipykernel:
+jupyter-ipykernel:
+jupyter-ipykernel:
+jupyter-ipykernel:
+jupyter-ipykernel:
+jupyter-ipykernel:
+jupyter-ipykernel: