summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--desktop/sync-engine/README5
-rw-r--r--desktop/sync-engine/slack-desc19
-rw-r--r--desktop/sync-engine/sync-engine.SlackBuild59
-rw-r--r--desktop/sync-engine/sync-engine.info8
4 files changed, 91 insertions, 0 deletions
diff --git a/desktop/sync-engine/README b/desktop/sync-engine/README
new file mode 100644
index 0000000000..0eb182061d
--- /dev/null
+++ b/desktop/sync-engine/README
@@ -0,0 +1,5 @@
+sync-engine is SynCE's syncronization engine, which is required
+to make partnerships between the computer and the device.
+Partnerships allow you to specify which items to sync.
+
+This requires libsynce, librapi2, librra, synce-hal, and pysetuptools.
diff --git a/desktop/sync-engine/slack-desc b/desktop/sync-engine/slack-desc
new file mode 100644
index 0000000000..bed9a3d8f4
--- /dev/null
+++ b/desktop/sync-engine/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------------|
+sync-engine: sync-engine (SynCE syncronization engine)
+sync-engine:
+sync-engine: sync-engine is SynCE's syncronization engine, which is required
+sync-engine: to make partnerships between the computer and the device.
+sync-engine:
+sync-engine: Partnerships allow you to specify which items to sync.
+sync-engine:
+sync-engine: Homepage: http://www.synce.org/
+sync-engine:
+sync-engine:
+sync-engine:
diff --git a/desktop/sync-engine/sync-engine.SlackBuild b/desktop/sync-engine/sync-engine.SlackBuild
new file mode 100644
index 0000000000..98172ead70
--- /dev/null
+++ b/desktop/sync-engine/sync-engine.SlackBuild
@@ -0,0 +1,59 @@
+#!/bin/sh
+# Slackware build script for sync-engine
+# Written by Lionel Young (redtricycle@gmail.com)
+
+PRGNAM=sync-engine
+VERSION=${VERSION:-0.13}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/usr/share/doc/sync-engine/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share
+( cd $PKG/usr/doc ; ln -s $PRGNAM-$VERSION $PRGNAM )
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/desktop/sync-engine/sync-engine.info b/desktop/sync-engine/sync-engine.info
new file mode 100644
index 0000000000..98e7dcea56
--- /dev/null
+++ b/desktop/sync-engine/sync-engine.info
@@ -0,0 +1,8 @@
+PRGNAM="sync-engine"
+VERSION="0.13"
+HOMEPAGE="http://www.synce.org"
+DOWNLOAD="http://downloads.sourceforge.net/synce/sync-engine-0.13.tar.gz"
+MD5SUM="6b3d776d0cbba16fb2b9e89c1ef84ba2"
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
+APPROVED="rworkman"