summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/Pafy/Pafy.SlackBuild16
-rw-r--r--network/Pafy/Pafy.info6
2 files changed, 14 insertions, 8 deletions
diff --git a/network/Pafy/Pafy.SlackBuild b/network/Pafy/Pafy.SlackBuild
index 8b1ca1a813..58a4735858 100644
--- a/network/Pafy/Pafy.SlackBuild
+++ b/network/Pafy/Pafy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Pafy
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,8 @@
PRGNAM=Pafy
-VERSION=${VERSION:-0.3.72}
+SRCNAM=${PRGNAM,,}
+VERSION=${VERSION:-0.3.74}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,9 +61,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -72,6 +73,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/network/Pafy/Pafy.info b/network/Pafy/Pafy.info
index e7e2ddec74..af36b9a1df 100644
--- a/network/Pafy/Pafy.info
+++ b/network/Pafy/Pafy.info
@@ -1,8 +1,8 @@
PRGNAM="Pafy"
-VERSION="0.3.72"
+VERSION="0.3.74"
HOMEPAGE="http://np1.github.io/pafy/"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pafy/Pafy-0.3.72.tar.gz"
-MD5SUM="f187d97432bf8a6ce2def245ab1b05a5"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pafy/pafy-0.3.74.tar.gz"
+MD5SUM="fbf0e7f85914eaf35f87837232eec09c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""