summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python3-pylyrics/README4
-rw-r--r--python/python3-pylyrics/python3-pylyrics.SlackBuild2
-rw-r--r--python/python3-pylyrics/slack-desc2
3 files changed, 5 insertions, 3 deletions
diff --git a/python/python3-pylyrics/README b/python/python3-pylyrics/README
index c10a196852..279d9c125f 100644
--- a/python/python3-pylyrics/README
+++ b/python/python3-pylyrics/README
@@ -1,5 +1,5 @@
-PyLyrics is a python module to get Lyrics of songs from
-lyrics.wikia.com. It has support for getting albums of a singer and
+PyLyrics is a python module to get Lyrics of songs from
+lyrics.wikia.com. It has support for getting albums of a singer and
songs from an album from which lyrics can be accessed.
By ~red
diff --git a/python/python3-pylyrics/python3-pylyrics.SlackBuild b/python/python3-pylyrics/python3-pylyrics.SlackBuild
index 6a60494871..3d71cc7d93 100644
--- a/python/python3-pylyrics/python3-pylyrics.SlackBuild
+++ b/python/python3-pylyrics/python3-pylyrics.SlackBuild
@@ -83,6 +83,8 @@ find -L . \
sed -i -e "s~.*scripts=glob.glob(\"Scripts/\*.py\"),~~" setup.py
+python3 -c 'from PyLyrics import classes'
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
diff --git a/python/python3-pylyrics/slack-desc b/python/python3-pylyrics/slack-desc
index 2d3dc7ee5c..5a966f649f 100644
--- a/python/python3-pylyrics/slack-desc
+++ b/python/python3-pylyrics/slack-desc
@@ -14,6 +14,6 @@ python3-pylyrics: It has support for getting albums of a singer and songs from a
python3-pylyrics: from which lyrics can be accessed.
python3-pylyrics:
python3-pylyrics:
+python3-pylyrics: Homepage: https://github.com/geekpradd/PyLyrics
python3-pylyrics:
python3-pylyrics:
-python3-pylyrics: Homepage: https://github.com/geekpradd/PyLyrics