summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/kombu/README9
-rw-r--r--python/kombu/kombu.SlackBuild69
-rw-r--r--python/kombu/kombu.info10
-rw-r--r--python/kombu/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/kombu/README b/python/kombu/README
new file mode 100644
index 0000000000..f83d04ed25
--- /dev/null
+++ b/python/kombu/README
@@ -0,0 +1,9 @@
+Kombu is a messaging library for Python.
+
+The aim of Kombu is to make messaging in Python as easy as possible by providing
+an idiomatic high-level interface for the AMQ protocol, and also provide proven
+and tested solutions to common messaging problems.
+
+AMQP is the Advanced Message Queuing Protocol, an open standard protocol for
+message orientation, queuing, routing, reliability and security, for which the
+RabbitMQ messaging server is the most popular implementation.
diff --git a/python/kombu/kombu.SlackBuild b/python/kombu/kombu.SlackBuild
new file mode 100644
index 0000000000..813390ba93
--- /dev/null
+++ b/python/kombu/kombu.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# SlackBuild script for kombu.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=kombu
+VERSION=${VERSION:-3.0.37}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/kombu/kombu.info b/python/kombu/kombu.info
new file mode 100644
index 0000000000..aaa44676c1
--- /dev/null
+++ b/python/kombu/kombu.info
@@ -0,0 +1,10 @@
+PRGNAM="kombu"
+VERSION="3.0.37"
+HOMEPAGE="https://kombu.readthedocs.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/k/kombu/kombu-3.0.37.tar.gz"
+MD5SUM="a1901036ba5e70e6b1733f7c2d5ee313"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="amqp anyjson"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/kombu/slack-desc b/python/kombu/slack-desc
new file mode 100644
index 0000000000..d6678e3e63
--- /dev/null
+++ b/python/kombu/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+kombu: kombu (messaging library for Python)
+kombu:
+kombu: The aim of Kombu is to make messaging in Python as easy as possible
+kombu: by providing an idiomatic high-level interface for the AMQ protocol,
+kombu: and also provide proven and tested solutions to common messaging
+kombu: problems.
+kombu:
+kombu:
+kombu:
+kombu:
+kombu: