summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/openimageio/README5
-rw-r--r--graphics/openimageio/oiio-include-cstdio.diff10
-rw-r--r--graphics/openimageio/openimageio.SlackBuild17
-rw-r--r--graphics/openimageio/openimageio.info8
4 files changed, 15 insertions, 25 deletions
diff --git a/graphics/openimageio/README b/graphics/openimageio/README
index c9f95f1486..e84c4c88dd 100644
--- a/graphics/openimageio/README
+++ b/graphics/openimageio/README
@@ -6,8 +6,3 @@ large-scale animation and visual effects work for film.
OpenImageIO is used extensively in animation and VFX studios all
over the world, and is also incorporated into several commercial
products.
-
-This package includes options for including a python3 module. Due to
-lack of python3 modules in the standard Slackware boost package,
-these options are quietly ignored but are maintained in the hope of
-future python3 support in Slackware's boost.
diff --git a/graphics/openimageio/oiio-include-cstdio.diff b/graphics/openimageio/oiio-include-cstdio.diff
index 703e86fe09..48d6aad832 100644
--- a/graphics/openimageio/oiio-include-cstdio.diff
+++ b/graphics/openimageio/oiio-include-cstdio.diff
@@ -1,10 +1,10 @@
---- src/jpeg2000.imageio/jpeg2000output-v1.cpp.orig 2017-08-31 14:36:04.000000000 +1000
-+++ src/jpeg2000.imageio/jpeg2000output-v1.cpp 2017-10-30 10:34:45.122572637 +1000
-@@ -27,6 +27,7 @@
-
+--- src/jpeg2000.imageio/jpeg2000output-v1.cpp.orig 2019-08-02 13:53:54.000000000 +1000
++++ src/jpeg2000.imageio/jpeg2000output-v1.cpp 2019-08-07 21:54:04.354000000 +1000
+@@ -28,6 +28,7 @@
(This is the Modified BSD License)
*/
+
+#include <cstdio>
#include <vector>
+
#include "openjpeg.h"
- #include "OpenImageIO/filesystem.h"
diff --git a/graphics/openimageio/openimageio.SlackBuild b/graphics/openimageio/openimageio.SlackBuild
index f96cd057de..0e7e19edb3 100644
--- a/graphics/openimageio/openimageio.SlackBuild
+++ b/graphics/openimageio/openimageio.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for openimageio
-# Copyright 2015-2018 Christoph Willing Brisbane, Australia
+# Copyright 2015-2019 Christoph Willing Brisbane, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=openimageio
SRCNAM=oiio-Release
-VERSION=${VERSION:-1.8.16}
+VERSION=${VERSION:-2.0.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,9 +74,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Remove bundled pugixml
-#rm -f src/include/OpenImageIO/pugi*
-
# save this for GCC 7.0
#sed -i "s|std=c++11|std=c++11 -Wno-error=maybe-uninitialized -Wno-error=format-truncation -Wno-error=noexcept-type -faligned-new|" CMakeLists.txt
@@ -86,19 +83,17 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
-DOPENJPEG_INCLUDE_DIR="/usr/include/openmj2-2.1" \
- -DOPENJPEG_OPENJPEG_LIBRARIES="openmj2" \
+ -DOPENJPEG_OPENJPEG_LIBRARY_RELEASE="/usr/lib${LIBDIRSUFFIX}/libopenmj2.so" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DDOC_INSTALL_DIR:PATH=doc/$PRGNAM-$VERSION \
- -DLIB_INSTALL_DIR:PATH=lib$LIBDIRSUFFIX \
- -DPYLIB_INSTALL_DIR:PATH=$PYLIB_INSTALL_DIRECTORY \
- -DPYLIB3_INSTALL_DIR:PATH=$PYLIB3_INSTALL_DIRECTORY \
-DPYLIB_INCLUDE_SONAME:BOOL=TRUE \
-DPYLIB_LIB_PREFIX:BOOL=FALSE \
-DUSE_OCIO:BOOL=TRUE \
+ -DUSE_OPENJPEG:BOOL=TRUE \
+ -DOIIO_BUILD_TESTS:BOOL=FALSE \
-DUSE_PYTHON:BOOL=TRUE \
- -DUSE_PYTHON3:BOOL=TRUE \
-DUSE_EXTERNAL_PUGIXML:BOOL=FALSE \
+ -DPYBIND11_INCLUDE_DIR:STRING=/usr/include/python2.7 \
make
make install DESTDIR=$PKG
diff --git a/graphics/openimageio/openimageio.info b/graphics/openimageio/openimageio.info
index 54e5a70dcb..9bec5deaf9 100644
--- a/graphics/openimageio/openimageio.info
+++ b/graphics/openimageio/openimageio.info
@@ -1,10 +1,10 @@
PRGNAM="openimageio"
-VERSION="1.8.16"
+VERSION="2.0.10"
HOMEPAGE="https://sites.google.com/site/openimageio/home"
-DOWNLOAD="https://github.com/OpenImageIO/oiio/archive/Release-1.8.16/oiio-Release-1.8.16.tar.gz"
-MD5SUM="2f78d487066511bae3b04415aef7f788"
+DOWNLOAD="https://github.com/OpenImageIO/oiio/archive/Release-2.0.10/oiio-Release-2.0.10.tar.gz"
+MD5SUM="869005749cdbb88605f03b0625ca2085"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="ffmpeg libwebp opencv opencolorio"
+REQUIRES="ffmpeg libwebp opencv opencolorio pybind11 robin-map qt5 dcmtk"
MAINTAINER="Christoph Willing"
EMAIL="chris.willing@linux.com"