summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gis/geopy/README9
-rw-r--r--gis/geopy/geopy.SlackBuild39
-rw-r--r--gis/geopy/geopy.info6
-rw-r--r--gis/geopy/slack-desc12
4 files changed, 44 insertions, 22 deletions
diff --git a/gis/geopy/README b/gis/geopy/README
index a259e8cd30..a235b18e15 100644
--- a/gis/geopy/README
+++ b/gis/geopy/README
@@ -1,9 +1,8 @@
geopy makes it easy for developers to locate the coordinates of addresses,
cities, countries, and landmarks across the globe using third-party
-geocoders and other data sources, such as wikis.
+geocoders and other data sources.
-geopy currently includes support for six geocoders: Google Maps, Yahoo!
-Maps, Windows Local Live (Virtual Earth), geocoder.us, GeoNames, MediaWiki
-pages (with the GIS extension), and Semantic MediaWiki pages.
+geopy currently includes support for several geocoders, including OpenStreetMap
+Nominatim, ESRI ArcGIS, Google Geocoding API and more.
-See http://code.google.com/p/geopy/wiki/GettingStarted for more details.
+python/pytz is an optional dependency that will be used if available.
diff --git a/gis/geopy/geopy.SlackBuild b/gis/geopy/geopy.SlackBuild
index baae4212cb..4a66b72a50 100644
--- a/gis/geopy/geopy.SlackBuild
+++ b/gis/geopy/geopy.SlackBuild
@@ -1,19 +1,39 @@
#!/bin/sh
-# SlackBuild for geopy python library
+# SlackBuild script for geopy
# Written by Dominik Drobek <dominik.drobek (at) o2.pl>
# Formerly maintained by Francisco Sokol <chico.sokol@gmail.com>
# Currently maintained by Benjamin Trigona-Harany
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=geopy
-VERSION=${VERSION:-1.11.0}
+VERSION=${VERSION:-1.12.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -24,8 +44,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -44,19 +64,22 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/gis/geopy/geopy.info b/gis/geopy/geopy.info
index 3df2ba2193..70036b81cd 100644
--- a/gis/geopy/geopy.info
+++ b/gis/geopy/geopy.info
@@ -1,8 +1,8 @@
PRGNAM="geopy"
-VERSION="1.11.0"
+VERSION="1.12.0"
HOMEPAGE="https://github.com/geopy/geopy"
-DOWNLOAD="https://github.com/geopy/geopy/archive/1.11.0.tar.gz"
-MD5SUM="7f0e8e258b3d69eb0762afbfad470768"
+DOWNLOAD="https://github.com/geopy/geopy/archive/1.12.0/geopy-1.12.0.tar.gz"
+MD5SUM="251778af872378488b177757b08c3df2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/gis/geopy/slack-desc b/gis/geopy/slack-desc
index 6ef7e0038c..9a383dff7d 100644
--- a/gis/geopy/slack-desc
+++ b/gis/geopy/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-geopy: geopy (A Geocoding Toolbox for Python)
+geopy: geopy (geocoding for Python)
geopy:
geopy: geopy makes it easy for developers to locate the coordinates of
geopy: addresses, cities, countries, and landmarks across the globe using
-geopy: third-party geocoders and other data sources, such as wikis.
+geopy: third-party geocoders.
geopy:
-geopy: geopy currently includes support for six geocoders: Google Maps,
-geopy: Yahoo! Maps, Windows Local Live (Virtual Earth), geocoder.us,
-geopy: GeoNames, MediaWiki pages (with the GIS extension), and Semantic
-geopy: MediaWiki pages.
+geopy: geopy currently includes support for several geocoders, including
+geopy: OpenStreetMap Nominatim, ESRI ArcGIS, Google Geocoding API and more.
+geopy:
+geopy:
geopy: