summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/cocos2d/README10
-rw-r--r--python/cocos2d/cocos2d.SlackBuild7
-rw-r--r--python/cocos2d/cocos2d.info6
3 files changed, 12 insertions, 11 deletions
diff --git a/python/cocos2d/README b/python/cocos2d/README
index 2fcecacd02..29c83cb96a 100644
--- a/python/cocos2d/README
+++ b/python/cocos2d/README
@@ -1,11 +1,11 @@
-cocos2d is a framework for building 2D games, demos,
-and other graphical/interactive applications.
+cocos2d is a Python framework for building 2D games,
+demos, and other graphical/interactive applications.
-It works on Windows, OS X and Linux and it is meant
-to be used by applications written in Python 2.x or 3.x
+To build for Python3:
+ # PYTHON=python3 ./cocos2d.SlackBuild
-Recommended Optional Dependencies
+Recommended optional dependencies:
numpy (for particles)
avbin (for sound and video)
diff --git a/python/cocos2d/cocos2d.SlackBuild b/python/cocos2d/cocos2d.SlackBuild
index 64bd6648fa..802409e2d0 100644
--- a/python/cocos2d/cocos2d.SlackBuild
+++ b/python/cocos2d/cocos2d.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for Cocos2d
-# Copyright 2017 Klaatu, Wellington NZ.
+# Copyright 2019 Klaatu | Lawrence NZ | klaatu@member.fsf.org
# GNU All-Permissive License
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
@@ -10,10 +10,11 @@
PRGNAM=cocos2d
SRCNAM=cocos
-VERSION=${VERSION:-0.6.4}
+VERSION=${VERSION:-0.6.7}
SRCVER=release-$VERSION
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PYTHON=${PYTHON:-python}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -43,7 +44,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+$PYTHON setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/cocos2d/cocos2d.info b/python/cocos2d/cocos2d.info
index a0b5ee77c0..96e8639f7c 100644
--- a/python/cocos2d/cocos2d.info
+++ b/python/cocos2d/cocos2d.info
@@ -1,8 +1,8 @@
PRGNAM="cocos2d"
-VERSION="0.6.4"
+VERSION="0.6.7"
HOMEPAGE="http://python.cocos2d.org/"
-DOWNLOAD="https://github.com/los-cocos/cocos/archive/release-0.6.4/cocos-release-0.6.4.tar.gz"
-MD5SUM="ae5ead930fb2629e0daeec696681a185"
+DOWNLOAD="https://github.com/los-cocos/cocos/archive/release-0.6.7/cocos-release-0.6.7.tar.gz"
+MD5SUM="ffbedf1663dcc7f77b4a55459f56d627"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pyglet"