summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/MySQL-python/MySQL-python.SlackBuild21
-rw-r--r--development/MySQL-python/MySQL-python.info8
-rw-r--r--development/MySQL-python/README2
-rw-r--r--development/MySQL-python/docs.patch14
-rw-r--r--development/MySQL-python/slack-desc12
5 files changed, 22 insertions, 35 deletions
diff --git a/development/MySQL-python/MySQL-python.SlackBuild b/development/MySQL-python/MySQL-python.SlackBuild
index 9b2ed4fcb1..7c6e30657c 100644
--- a/development/MySQL-python/MySQL-python.SlackBuild
+++ b/development/MySQL-python/MySQL-python.SlackBuild
@@ -3,18 +3,17 @@
# Slackware build script for MySQL-python.
# Written by Jick Nan (jick.nan@gmail.com)
+# Modified by the Slackbuilds.org project
PRGNAM=MySQL-python
-VERSION=1.2.3
+VERSION=1.2.4
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -44,21 +43,23 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+unzip $CWD/$PRGNAM-$VERSION.zip
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# patch MANIFEST.in
-patch -p1 < $CWD/docs.patch
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a HISTORY PKG-INFO README doc/*.txt \
+cp -a \
+ PKG-INFO doc/_build/_sources/FAQ.txt doc/_build/_sources/user_guide.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/development/MySQL-python/MySQL-python.info b/development/MySQL-python/MySQL-python.info
index e5402d05d1..8bf3ca6d68 100644
--- a/development/MySQL-python/MySQL-python.info
+++ b/development/MySQL-python/MySQL-python.info
@@ -1,8 +1,8 @@
PRGNAM="MySQL-python"
-VERSION="1.2.3"
-HOMEPAGE="http://cheeseshop.python.org/pypi/MySQL-python/"
-DOWNLOAD="http://downloads.sourceforge.net/mysql-python/MySQL-python-1.2.3.tar.gz"
-MD5SUM="215eddb6d853f6f4be5b4afc4154292f"
+VERSION="1.2.4"
+HOMEPAGE="http://pypi.python.org/pypi/MySQL-python"
+DOWNLOAD="http://pypi.python.org/packages/source/M/MySQL-python/MySQL-python-1.2.4.zip"
+MD5SUM="ddf2386daf10a97af115ffad2ed4a9a0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"
diff --git a/development/MySQL-python/README b/development/MySQL-python/README
index 8241994ae6..de40ed0a7d 100644
--- a/development/MySQL-python/README
+++ b/development/MySQL-python/README
@@ -7,4 +7,4 @@ The design goals are:
* Thread-safety
* Thread-friendliness (threads will not block each other)
-MySQL-3.23 through 5.1 and Python-2.3 through 2.6 are currently supported.
+MySQL-3.23 through 5.5 and Python-2.4 through 2.7 are currently supported.
diff --git a/development/MySQL-python/docs.patch b/development/MySQL-python/docs.patch
deleted file mode 100644
index 9c624b3547..0000000000
--- a/development/MySQL-python/docs.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- MySQL-python-1.2.3/MANIFEST.in.orig 2010-11-20 17:45:00.000000000 +0100
-+++ MySQL-python-1.2.3/MANIFEST.in 2010-11-20 17:45:30.000000000 +0100
-@@ -1,10 +1,8 @@
- recursive-include doc *.txt
- recursive-include tests *.py
- include MANIFEST.in
--include MANIFEST
--include ChangeLog
- include HISTORY
--include GPL
-+include README
- include pymemcompat.h
- include metadata.cfg
- include site.cfg
diff --git a/development/MySQL-python/slack-desc b/development/MySQL-python/slack-desc
index 3bdaf5389e..a90a2a5a21 100644
--- a/development/MySQL-python/slack-desc
+++ b/development/MySQL-python/slack-desc
@@ -5,15 +5,15 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
MySQL-python: MySQL-python (Python interface to MySQL)
-MySQL-python:
+MySQL-python:
MySQL-python: MySQLdb is an interface to the popular MySQL database server
-MySQL-python: for Python. The design goals are:
+MySQL-python: for Python. The design goals are:
MySQL-python: * Compliance with Python database API version 2.0 [PEP-0249]
MySQL-python: * Thread-safety
MySQL-python: * Thread-friendliness (threads will not block each other)
-MySQL-python:
-MySQL-python: MySQL-3.23 through 5.0 and Python-2.3 through 2.5 are currently
+MySQL-python: MySQL-3.23 through 5.5 and Python-2.4 through 2.7 are currently
MySQL-python: supported.
-MySQL-python:
+MySQL-python:
+MySQL-python: homepage: http://pypi.python.org/pypi/MySQL-python