summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/gearbox/README12
-rw-r--r--python/gearbox/gearbox.SlackBuild6
2 files changed, 8 insertions, 10 deletions
diff --git a/python/gearbox/README b/python/gearbox/README
index 911ad0d771..532387598f 100644
--- a/python/gearbox/README
+++ b/python/gearbox/README
@@ -1,8 +1,8 @@
Gearbox is a paster command replacement for TurboGears2.
-It has been created during the process of providing Python3 support to the
-TurboGears2 web framework, while still being backward compatible with the
-existing TurboGears projects.
+It has been created during the process of providing Python3 support to
+the TurboGears2 web framework, while still being backward compatible
+with the existing TurboGears projects.
-Gearbox is based on a stripped down version of Cliff command line framework,
-you might want to consider Cliff for more advanced use cases and custom
-command interpreters.
+Gearbox is based on a stripped down version of Cliff command line
+framework, you might want to consider Cliff for more advanced use cases
+and custom command interpreters.
diff --git a/python/gearbox/gearbox.SlackBuild b/python/gearbox/gearbox.SlackBuild
index 10bbe23791..de0f06528d 100644
--- a/python/gearbox/gearbox.SlackBuild
+++ b/python/gearbox/gearbox.SlackBuild
@@ -53,10 +53,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION