summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/fontmatrix/fontmatrix.SlackBuild27
-rw-r--r--graphics/fontmatrix/fontmatrix.info8
-rw-r--r--graphics/fontmatrix/slack-desc2
3 files changed, 15 insertions, 22 deletions
diff --git a/graphics/fontmatrix/fontmatrix.SlackBuild b/graphics/fontmatrix/fontmatrix.SlackBuild
index a0177b0317..a0378087f5 100644
--- a/graphics/fontmatrix/fontmatrix.SlackBuild
+++ b/graphics/fontmatrix/fontmatrix.SlackBuild
@@ -5,7 +5,7 @@
# Maintained by Klaatu <klaatu@member.fsf.org>
PRGNAM=fontmatrix
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-r1220}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -38,16 +38,13 @@ else
LIBDIRSUFFIX=""
fi
-# Decide if we compile fontmatrix with podofo support. Default is no.
-HAVE_PODOFO=${HAVE_PODOFO:-no}
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION-Source
-tar xvf $CWD/$PRGNAM-$VERSION-Source.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION-Source.tar.?z*
cd $PRGNAM-$VERSION-Source
chown -R root:root .
find . \
@@ -56,16 +53,16 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix the desktop menu item, location of man files, and PODOFO lib64 detection.
+# Fix the desktop menu item and location of man files.
echo "StartupNotify=false" >> $PRGNAM.desktop
sed -i 's|share/man|man|' CMakeLists.txt
-patch -p1 < $CWD/fix-podofo-detection.patch
+
# Cmake uses the static python lib. Let's use the shared lib instead.
PYVER=$(python -c 'import sys; print sys.version[:3]')
PY_LIB_SHARED="/usr/lib${LIBDIRSUFFIX}/libpython${PYVER}.so"
-# Decide if we use PODOFO.
-if [ "${HAVE_PODOFO}" == "yes" ]; then
+# Decide if we want PODOFO support (default is no).
+if [ "${HAVE_PODOFO:-no}" == "yes" ]; then
USE_PODOFO="TRUE"
else
USE_PODOFO="FALSE"
@@ -76,9 +73,7 @@ mkdir build && cd build
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DPYTHON_LIBRARY:PATH="$PY_LIB_SHARED" \
- -DOWN_SHAPER:BOOL=1 \
-DCMAKE_SKIP_RPATH:BOOL=1 \
- -DRPATH_STYLE:STRING=none \
-DWANT_ICU:BOOL=true \
-DWANT_M17N:BOOL=true \
-DWANT_PYTHONQT:BOOL=true \
@@ -96,13 +91,11 @@ mkdir build && cd build
make install DESTDIR=$PKG
cd ..
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
rm -rf $PKG/usr/share/icons
for i in 16 22 32 48 64 128; do
@@ -113,7 +106,7 @@ done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- COPYING INSTALL TODO harfbuzz/{COPYING.*,README,AUTHORS} \
+ COPYING ChangeLog TODO harfbuzz/{COPYING.*,README,AUTHORS} \
$PKG/usr/doc/$PRGNAM-$VERSION
cat harfbuzz/COPYING > $PKG/usr/doc/$PRGNAM-$VERSION/COPYING.harfbuzz
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/graphics/fontmatrix/fontmatrix.info b/graphics/fontmatrix/fontmatrix.info
index 5c348a2e4b..2ac31d1917 100644
--- a/graphics/fontmatrix/fontmatrix.info
+++ b/graphics/fontmatrix/fontmatrix.info
@@ -1,8 +1,8 @@
PRGNAM="fontmatrix"
-VERSION="0.6.0"
-HOMEPAGE="http://fontmatrix.net/"
-DOWNLOAD="http://slackbuilds.slackadelic.com/graphics/fontmatrix/fontmatrix-0.6.0-Source.tar.gz"
-MD5SUM="6a00c9448a50d3bab5acb4145f778f2d"
+VERSION="r1220"
+HOMEPAGE="http://fontmatrix.be/"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/fontmatrix-r1220-Source.tar.xz"
+MD5SUM="fa908bca2306706a7fae162abfd1e9f4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/graphics/fontmatrix/slack-desc b/graphics/fontmatrix/slack-desc
index 0c43275b63..a801229cd0 100644
--- a/graphics/fontmatrix/slack-desc
+++ b/graphics/fontmatrix/slack-desc
@@ -12,7 +12,7 @@ fontmatrix: fontmatrix is a manager built with the kind of features and abilitie
fontmatrix: graphic designers, layout professionals, and others have felt
fontmatrix: necessary, but modernized with some new touches.
fontmatrix:
-fontmatrix: Homepage: http://fontmatrix.net/
+fontmatrix: Homepage: http://fontmatrix.be/
fontmatrix:
fontmatrix:
fontmatrix: