summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--accessibility/jpilot/doinst.sh4
-rw-r--r--accessibility/jpilot/jpilot-1.6.2-fixup_plugins_libdir.diff228
-rw-r--r--accessibility/jpilot/jpilot.SlackBuild22
-rw-r--r--accessibility/jpilot/jpilot.info10
-rw-r--r--accessibility/jpilot/slack-desc9
5 files changed, 261 insertions, 12 deletions
diff --git a/accessibility/jpilot/doinst.sh b/accessibility/jpilot/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/accessibility/jpilot/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/accessibility/jpilot/jpilot-1.6.2-fixup_plugins_libdir.diff b/accessibility/jpilot/jpilot-1.6.2-fixup_plugins_libdir.diff
new file mode 100644
index 0000000000..b8251c64f2
--- /dev/null
+++ b/accessibility/jpilot/jpilot-1.6.2-fixup_plugins_libdir.diff
@@ -0,0 +1,228 @@
+This is a fairly trivial patch to avoid violating POLA when --libdir
+is specified. --rworkman
+
+diff -Nur jpilot-1.6.2.orig/Expense/Makefile.in jpilot-1.6.2/Expense/Makefile.in
+--- jpilot-1.6.2.orig/Expense/Makefile.in 2009-02-15 15:18:34.000000000 -0600
++++ jpilot-1.6.2/Expense/Makefile.in 2009-07-11 00:38:17.958608728 -0500
+@@ -22,7 +22,7 @@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
+ pkgdatadir = $(datadir)/@PACKAGE@
+-pkglibdir = $(libdir)/@PACKAGE@
++pkglibdir = @libdir@/@PACKAGE@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ top_builddir = ..
+ am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+@@ -53,7 +53,7 @@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
+ CONFIG_CLEAN_FILES =
+-am__installdirs = "$(DESTDIR)$(libdir)"
++am__installdirs = "$(DESTDIR)$(pluginlibdir)"
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ libexpense_la_LIBADD =
+@@ -230,7 +230,7 @@
+ includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+-libdir = $(prefix)/lib/jpilot/plugins
++pluginlibdir = $(pkglibdir)/plugins
+ libexecdir = @libexecdir@
+ localedir = @localedir@
+ localstatedir = @localstatedir@
+@@ -284,12 +284,12 @@
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ install-libLTLIBRARIES: $(lib_LTLIBRARIES)
+ @$(NORMAL_INSTALL)
+- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
++ test -z "$(pluginlibdir)" || $(mkdir_p) "$(DESTDIR)$(pluginlibdir)"
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
+- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
++ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(pluginlibdir)/$$f'"; \
++ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(pluginlibdir)/$$f"; \
+ else :; fi; \
+ done
+
+@@ -297,8 +297,8 @@
+ @$(NORMAL_UNINSTALL)
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ p="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(libdir)/$$p'"; \
+- $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(libdir)/$$p"; \
++ echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(pluginlibdir)/$$p'"; \
++ $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(pluginlibdir)/$$p"; \
+ done
+
+ clean-libLTLIBRARIES:
+@@ -310,7 +310,7 @@
+ rm -f "$${dir}/so_locations"; \
+ done
+ libexpense.la: $(libexpense_la_OBJECTS) $(libexpense_la_DEPENDENCIES)
+- $(LINK) -rpath $(libdir) $(libexpense_la_LDFLAGS) $(libexpense_la_OBJECTS) $(libexpense_la_LIBADD) $(LIBS)
++ $(LINK) -rpath $(pluginlibdir) $(libexpense_la_LDFLAGS) $(libexpense_la_OBJECTS) $(libexpense_la_LIBADD) $(LIBS)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)
+@@ -457,7 +457,7 @@
+ check: check-am
+ all-am: Makefile $(LTLIBRARIES)
+ installdirs:
+- for dir in "$(DESTDIR)$(libdir)"; do \
++ for dir in "$(DESTDIR)$(pluginlibdir)"; do \
+ test -z "$$dir" || $(mkdir_p) "$$dir"; \
+ done
+ install: install-am
+diff -Nur jpilot-1.6.2.orig/KeyRing/Makefile.in jpilot-1.6.2/KeyRing/Makefile.in
+--- jpilot-1.6.2.orig/KeyRing/Makefile.in 2009-02-15 15:18:34.000000000 -0600
++++ jpilot-1.6.2/KeyRing/Makefile.in 2009-07-11 00:36:45.615683456 -0500
+@@ -22,7 +22,7 @@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
+ pkgdatadir = $(datadir)/@PACKAGE@
+-pkglibdir = $(libdir)/@PACKAGE@
++pkglibdir = @libdir@/@PACKAGE@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ top_builddir = ..
+ am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+@@ -53,7 +53,7 @@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
+ CONFIG_CLEAN_FILES =
+-am__installdirs = "$(DESTDIR)$(libdir)"
++am__installdirs = "$(DESTDIR)$(pluginlibdir)"
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ libkeyring_la_LIBADD =
+@@ -230,7 +230,7 @@
+ includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+-libdir = $(prefix)/lib/jpilot/plugins
++pluginlibdir = $(pkglibdir)/plugins
+ libexecdir = @libexecdir@
+ localedir = @localedir@
+ localstatedir = @localstatedir@
+@@ -285,12 +285,12 @@
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ install-libLTLIBRARIES: $(lib_LTLIBRARIES)
+ @$(NORMAL_INSTALL)
+- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
++ test -z "$(pluginlibdir)" || $(mkdir_p) "$(DESTDIR)$(pluginlibdir)"
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
+- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
++ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(pluginlibdir)/$$f'"; \
++ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(pluginlibdir)/$$f"; \
+ else :; fi; \
+ done
+
+@@ -298,8 +298,8 @@
+ @$(NORMAL_UNINSTALL)
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ p="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(libdir)/$$p'"; \
+- $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(libdir)/$$p"; \
++ echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(pluginlibdir)/$$p'"; \
++ $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(pluginlibdir)/$$p"; \
+ done
+
+ clean-libLTLIBRARIES:
+@@ -311,7 +311,7 @@
+ rm -f "$${dir}/so_locations"; \
+ done
+ libkeyring.la: $(libkeyring_la_OBJECTS) $(libkeyring_la_DEPENDENCIES)
+- $(LINK) -rpath $(libdir) $(libkeyring_la_LDFLAGS) $(libkeyring_la_OBJECTS) $(libkeyring_la_LIBADD) $(LIBS)
++ $(LINK) -rpath $(pluginlibdir) $(libkeyring_la_LDFLAGS) $(libkeyring_la_OBJECTS) $(libkeyring_la_LIBADD) $(LIBS)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)
+@@ -458,7 +458,7 @@
+ check: check-am
+ all-am: Makefile $(LTLIBRARIES)
+ installdirs:
+- for dir in "$(DESTDIR)$(libdir)"; do \
++ for dir in "$(DESTDIR)$(pluginlibdir)"; do \
+ test -z "$$dir" || $(mkdir_p) "$$dir"; \
+ done
+ install: install-am
+diff -Nur jpilot-1.6.2.orig/SyncTime/Makefile.in jpilot-1.6.2/SyncTime/Makefile.in
+--- jpilot-1.6.2.orig/SyncTime/Makefile.in 2009-02-15 15:18:34.000000000 -0600
++++ jpilot-1.6.2/SyncTime/Makefile.in 2009-07-11 00:36:58.331536319 -0500
+@@ -22,7 +22,7 @@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
+ pkgdatadir = $(datadir)/@PACKAGE@
+-pkglibdir = $(libdir)/@PACKAGE@
++pkglibdir = @libdir@/@PACKAGE@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ top_builddir = ..
+ am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+@@ -53,7 +53,7 @@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
+ CONFIG_CLEAN_FILES =
+-am__installdirs = "$(DESTDIR)$(libdir)"
++am__installdirs = "$(DESTDIR)$(pluginlibdir)"
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ libsynctime_la_LIBADD =
+@@ -230,7 +230,7 @@
+ includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+-libdir = $(prefix)/lib/jpilot/plugins
++pluginlibdir = $(pkglibdir)/plugins
+ libexecdir = @libexecdir@
+ localedir = @localedir@
+ localstatedir = @localstatedir@
+@@ -284,12 +284,12 @@
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ install-libLTLIBRARIES: $(lib_LTLIBRARIES)
+ @$(NORMAL_INSTALL)
+- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
++ test -z "$(pluginlibdir)" || $(mkdir_p) "$(DESTDIR)$(pluginlibdir)"
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
+- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
++ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(pluginlibdir)/$$f'"; \
++ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(pluginlibdir)/$$f"; \
+ else :; fi; \
+ done
+
+@@ -297,8 +297,8 @@
+ @$(NORMAL_UNINSTALL)
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ p="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(libdir)/$$p'"; \
+- $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(libdir)/$$p"; \
++ echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(pluginlibdir)/$$p'"; \
++ $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(pluginlibdir)/$$p"; \
+ done
+
+ clean-libLTLIBRARIES:
+@@ -310,7 +310,7 @@
+ rm -f "$${dir}/so_locations"; \
+ done
+ libsynctime.la: $(libsynctime_la_OBJECTS) $(libsynctime_la_DEPENDENCIES)
+- $(LINK) -rpath $(libdir) $(libsynctime_la_LDFLAGS) $(libsynctime_la_OBJECTS) $(libsynctime_la_LIBADD) $(LIBS)
++ $(LINK) -rpath $(pluginlibdir) $(libsynctime_la_LDFLAGS) $(libsynctime_la_OBJECTS) $(libsynctime_la_LIBADD) $(LIBS)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)
+@@ -457,7 +457,7 @@
+ check: check-am
+ all-am: Makefile $(LTLIBRARIES)
+ installdirs:
+- for dir in "$(DESTDIR)$(libdir)"; do \
++ for dir in "$(DESTDIR)$(pluginlibdir)"; do \
+ test -z "$$dir" || $(mkdir_p) "$$dir"; \
+ done
+ install: install-am
diff --git a/accessibility/jpilot/jpilot.SlackBuild b/accessibility/jpilot/jpilot.SlackBuild
index 1e05af047c..f03c88605f 100644
--- a/accessibility/jpilot/jpilot.SlackBuild
+++ b/accessibility/jpilot/jpilot.SlackBuild
@@ -24,11 +24,8 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-set -e
-
PRGNAM=jpilot
-VERSION=${VERSION:-1.6.0}
+VERSION=${VERSION:-1.6.2}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,16 +37,21 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLCKFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP rm -rf $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -58,14 +60,19 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Use correct libdir for the plugins
+patch -p1 < $CWD/jpilot-1.6.2-fixup_plugins_libdir.diff
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --docdir=/usr/doc
+ --docdir=/usr/doc \
+ --build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
@@ -82,6 +89,7 @@ find $PKG/usr/doc -type f -exec chmod 644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/accessibility/jpilot/jpilot.info b/accessibility/jpilot/jpilot.info
index 7368f6310e..3a77ed71b1 100644
--- a/accessibility/jpilot/jpilot.info
+++ b/accessibility/jpilot/jpilot.info
@@ -1,8 +1,10 @@
PRGNAM="jpilot"
-VERSION="1.6.0"
+VERSION="1.6.2"
HOMEPAGE="http://www.jpilot.org"
-DOWNLOAD="http://jpilot.org/jpilot-1.6.0.tar.gz"
-MD5SUM="7918d345fb7e4b644a7211db03ddd148"
+DOWNLOAD="http://jpilot.org/jpilot-1.6.2.tar.gz"
+MD5SUM="72967dee4a1715ebe27e50e12f1e63d8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="alkos333"
EMAIL="me@alkos333.net"
-APPROVED="David Somero" \ No newline at end of file
+APPROVED="David Somero"
diff --git a/accessibility/jpilot/slack-desc b/accessibility/jpilot/slack-desc
index 2fe9df9f46..87d1c80b69 100644
--- a/accessibility/jpilot/slack-desc
+++ b/accessibility/jpilot/slack-desc
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
|-----handy-ruler------------------------------------------------------|
jpilot: J-Pilot (desktop organizer application for PalmOS devices)
jpilot:
@@ -5,8 +12,8 @@ jpilot: J-Pilot is a desktop organizer application for PalmOS devices. It is
jpilot: meant to be an alternative to the Palm Desktop for those who run the
jpilot: most popular Operating Systems in the World, Linux and Unix.
jpilot:
+jpilot: Homepage: http://www.jpilot.org
jpilot:
jpilot:
jpilot:
-jpilot: Homepage: http://www.jpilot.org
jpilot: