summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/tagpy/README3
-rw-r--r--python/tagpy/slack-desc19
-rw-r--r--python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch30
-rw-r--r--python/tagpy/tagpy.SlackBuild94
-rw-r--r--python/tagpy/tagpy.info10
5 files changed, 156 insertions, 0 deletions
diff --git a/python/tagpy/README b/python/tagpy/README
new file mode 100644
index 0000000000..5ccdaec9ad
--- /dev/null
+++ b/python/tagpy/README
@@ -0,0 +1,3 @@
+TagPy is a set of Python bindings for Scott Wheeler's TagLib. It
+builds upon Boost.Python, a wrapper generation library which is
+part of the Boost set of C++ libraries.
diff --git a/python/tagpy/slack-desc b/python/tagpy/slack-desc
new file mode 100644
index 0000000000..d4489ebfba
--- /dev/null
+++ b/python/tagpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+tagpy: TagPy (Python Bindings for TagLib)
+tagpy:
+tagpy: TagPy is a set of Python bindings for Scott Wheeler's TagLib. It
+tagpy: builds upon Boost.Python, a wrapper generation library which is
+tagpy: part of the Boost set of C++ libraries.
+tagpy:
+tagpy: Homepage: http://mathema.tician.de/software/tagpy
+tagpy:
+tagpy:
+tagpy:
+tagpy:
diff --git a/python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch b/python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch
new file mode 100644
index 0000000000..e6c9bef1d0
--- /dev/null
+++ b/python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch
@@ -0,0 +1,30 @@
+https://github.com/inducer/tagpy/commit/d0759c0ec7d24ae8d1af395a1032521eb00b4d1f
+https://github.com/inducer/tagpy/commit/813ec4f03bb4411c7ffd15dcb3974da04a3f109c
+
+--- tagpy-0.94.8/src/wrapper/id3.cpp
++++ tagpy-0.94.8/src/wrapper/id3.cpp
+@@ -79,6 +79,10 @@
+ MF_OL(setVolumeAdjustment, 1, 2);
+ MF_OL(setPeakVolume, 1, 2);
+
++ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
++ MF_OL(render, 0, 1)
++ #endif
++
+ // -------------------------------------------------------------
+ // MPEG
+ // -------------------------------------------------------------
+@@ -212,7 +216,12 @@
+ .DEF_SIMPLE_METHOD(removeFrame)
+ .DEF_SIMPLE_METHOD(removeFrames)
+
+- .DEF_SIMPLE_METHOD(render)
++ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
++ .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)() const)
++ .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)(int) const)
++ #else
++ .def("render", (ByteVector (cl::*)() const) &cl::render)
++ #endif
+ ;
+ }
+
diff --git a/python/tagpy/tagpy.SlackBuild b/python/tagpy/tagpy.SlackBuild
new file mode 100644
index 0000000000..470f6fde79
--- /dev/null
+++ b/python/tagpy/tagpy.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for TagPy
+
+# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tagpy
+VERSION=${VERSION:-0.94.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z* || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Remove ez_setup. We don't want to download distribute.
+sed -i -e '/distribute_setup/d' -e "s/^if.*/if False:/" aksetup_helper.py
+
+patch -p1 < $CWD/tagpy-0.94.8-taglib-1.8_compat.patch
+
+./configure.py \
+ --taglib-inc-dir="/usr/include/taglib" \
+ --boost-python-libname="boost_python" \
+ --boost-inc-dir="/usr/include/boost" \
+ --boost-lib-dir="/usr/lib${LIBDIRSUFFIX}" \
+ || exit 1
+
+python setup.py build || exit 1
+python setup.py install --root $PKG || exit 1
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/tagpy/tagpy.info b/python/tagpy/tagpy.info
new file mode 100644
index 0000000000..460a02c27f
--- /dev/null
+++ b/python/tagpy/tagpy.info
@@ -0,0 +1,10 @@
+PRGNAM="tagpy"
+VERSION="0.94.8"
+HOMEPAGE="http://mathema.tician.de/software/tagpy"
+DOWNLOAD="http://pypi.python.org/packages/source/t/tagpy/tagpy-0.94.8.tar.gz"
+MD5SUM="6baff63318cf90b9bc5a2497a0597802"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Frank Caraballo"
+EMAIL="fecaraballo{at}gmail{dot}com"