summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/lockfile/README5
-rw-r--r--python/lockfile/lockfile.SlackBuild3
2 files changed, 7 insertions, 1 deletions
diff --git a/python/lockfile/README b/python/lockfile/README
index fbfc355f8c..118cb27957 100644
--- a/python/lockfile/README
+++ b/python/lockfile/README
@@ -6,3 +6,8 @@ functions, and the deprecated posixfile module, the API is identical
across both Unix (including Linux and Mac) and Windows platforms.
This package is version 0.8 due to some API breakage in 0.9+
+
+To build for Python 3:
+
+ # PYTHON=python3 ./lockfile.SlackBuild
+ \ No newline at end of file
diff --git a/python/lockfile/lockfile.SlackBuild b/python/lockfile/lockfile.SlackBuild
index c168b87833..f8db698bc8 100644
--- a/python/lockfile/lockfile.SlackBuild
+++ b/python/lockfile/lockfile.SlackBuild
@@ -14,6 +14,7 @@ PRGNAM=lockfile
VERSION=${VERSION:-0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+TAG=${PYTHON:-python}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -57,7 +58,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+$PYTHON setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true