summaryrefslogtreecommitdiffstats
path: root/academic/PhyML/PhyML.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/PhyML/PhyML.SlackBuild')
-rw-r--r--academic/PhyML/PhyML.SlackBuild68
1 files changed, 36 insertions, 32 deletions
diff --git a/academic/PhyML/PhyML.SlackBuild b/academic/PhyML/PhyML.SlackBuild
index 41e235cda0..351fde6f1f 100644
--- a/academic/PhyML/PhyML.SlackBuild
+++ b/academic/PhyML/PhyML.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PhyML
-# Copyright 2011-2021 Petar Petrov slackalaxy@gmail.com
+# Copyright 2011-2022 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=PhyML
-VERSION=${VERSION:-3.3.20200621}
+VERSION=${VERSION:-3.3.20220408}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -123,45 +123,49 @@ sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
-# This is Phyrex
-./autogen.sh
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-phyrex \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-# Use our CFLAGS
+# This is Phyrex but it breaks at the moment
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-phyrex \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+ # Use our CFLAGS
sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
-# This is PhyTime
-./autogen.sh
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-phytime \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-
-CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
-make install DESTDIR=$PKG
+# # This is PhyTime
+# ./autogen.sh
+# ./configure \
+# --prefix=/usr \
+# --libdir=/usr/lib${LIBDIRSUFFIX} \
+# --sysconfdir=/etc \
+# --localstatedir=/var \
+# --mandir=/usr/man \
+# --enable-phytime \
+# --docdir=/usr/doc/$PRGNAM-$VERSION \
+# --build=$ARCH-slackware-linux
+#
+# # Use our CFLAGS
+# sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
+#
+# CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
+# make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# fix permissions for docs
+chmod 0644 doc/*.{pdf,tex,bib}
+chmod 0644 doc/fig/*.pdf
+
# Include some examples
mkdir -p $PKG/usr/share/$PRGNAM
cp -a examples $PKG/usr/share/$PRGNAM