summaryrefslogtreecommitdiffstats
path: root/academic/dwave-greedy
diff options
context:
space:
mode:
Diffstat (limited to 'academic/dwave-greedy')
-rw-r--r--academic/dwave-greedy/README13
-rw-r--r--academic/dwave-greedy/dwave-greedy.SlackBuild120
-rw-r--r--academic/dwave-greedy/dwave-greedy.info10
-rw-r--r--academic/dwave-greedy/slack-desc19
4 files changed, 162 insertions, 0 deletions
diff --git a/academic/dwave-greedy/README b/academic/dwave-greedy/README
new file mode 100644
index 0000000000..3e3fb8d475
--- /dev/null
+++ b/academic/dwave-greedy/README
@@ -0,0 +1,13 @@
+ An implementation of a steepest descent solver for binary quadratic
+models.
+
+ Steepest descent is the discrete analogue of gradient descent, but
+the best move is computed using a local minimization rather rather
+than computing a gradient. At each step, we determine the dimension
+along which to descend based on the highest energy drop caused by a
+variable flip.
+
+
+ Optional building mode set with environment variables:
+ - TESTS=yes (performs tests, requires dimod)
+
diff --git a/academic/dwave-greedy/dwave-greedy.SlackBuild b/academic/dwave-greedy/dwave-greedy.SlackBuild
new file mode 100644
index 0000000000..62db8ce464
--- /dev/null
+++ b/academic/dwave-greedy/dwave-greedy.SlackBuild
@@ -0,0 +1,120 @@
+#!/bin/bash
+
+# Slackware build script for dwave-greedy
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM="dwave-greedy"
+VERSION=${VERSION:-0.2.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python3 setup.py install --root=$PKG
+
+make -C tests
+if [ "${TESTS:-no}" == "yes" ]; then
+ IGNORE_TESTS="test_(composite|sampler).py"
+ PYVER=$( python3 -c 'import sys; print( "%d.%d" % sys.version_info[:2] )' )
+ cd tests
+ for file in $(ls test_*.py | grep -v -E $IGNORE_TESTS); do
+ echo -n "$file "
+ PYTHONPATH=../build/lib.linux-$(uname -m)-$PYVER python3 $file
+ if [ "$?" -eq "0" ]; then
+ echo "OK"
+ else
+ echo "\n$file - fail"
+ fi
+ done
+ cd ..
+fi
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/dwave-greedy/dwave-greedy.info b/academic/dwave-greedy/dwave-greedy.info
new file mode 100644
index 0000000000..a3c9b5ee9e
--- /dev/null
+++ b/academic/dwave-greedy/dwave-greedy.info
@@ -0,0 +1,10 @@
+PRGNAM="dwave-greedy"
+VERSION="0.2.5"
+HOMEPAGE="https://github.com/dwavesystems/dwave-greedy"
+DOWNLOAD="https://github.com/dwavesystems/dwave-greedy/archive/0.2.5/dwave-greedy-0.2.5.tar.gz"
+MD5SUM="8805c6bfa59c9b33d1e00e713e62fb98"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-numpy"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/academic/dwave-greedy/slack-desc b/academic/dwave-greedy/slack-desc
new file mode 100644
index 0000000000..15d483f32f
--- /dev/null
+++ b/academic/dwave-greedy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dwave-greedy: dwave-greedy (Implementation of a steepest descent solver for (BQM))
+dwave-greedy:
+dwave-greedy: An implementation of a steepest descent solver for binary
+dwave-greedy: quadratic models.
+dwave-greedy: Steepest descent is the discrete analogue of gradient descent,
+dwave-greedy: but the best move is computed using a local minimization rather
+dwave-greedy: rather than computing a gradient. At each step, we determine the
+dwave-greedy: dimension along which to descend based on the highest energy drop
+dwave-greedy: caused by a variable flip.
+dwave-greedy:
+dwave-greedy: