summaryrefslogtreecommitdiffstats
path: root/academic/hyphy/hyphy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/hyphy/hyphy.SlackBuild')
-rw-r--r--academic/hyphy/hyphy.SlackBuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/academic/hyphy/hyphy.SlackBuild b/academic/hyphy/hyphy.SlackBuild
index bbcde5d9a3..e22cf3435a 100644
--- a/academic/hyphy/hyphy.SlackBuild
+++ b/academic/hyphy/hyphy.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=hyphy
-VERSION=${VERSION:-2.3.13}
+VERSION=${VERSION:-2.3.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,21 +69,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix the libraries path on 64 systems
+# Fix the libraries path on 64 systems and use our compiler flags
sed -i "s:lib/hyphy:lib${LIBDIRSUFFIX}/hyphy:g" CMakeLists.txt
+sed -i "s:-msse3:$SLKCFLAGS:g" CMakeLists.txt
+sed -i "s:-march=corei7-avx -mtune=corei7-avx:$SLKCFLAGS:g" CMakeLists.txt
+sed -i "s:-mno-avx:$SLKCFLAGS:g" CMakeLists.txt
+sed -i "s:-mno-sse3:$SLKCFLAGS:g" CMakeLists.txt
+sed -i "s:-fsigned-char -O3:$SLKCFLAGS:g" CMakeLists.txt
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_REQUIRED_FLAGS="$SLKCFLAGS" \
- -DDEFAULT_COMPILE_FLAGS="$SLKCFLAGS" \
- -DINSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
-# This builds build a HyPhy executable (HYPHYMP) using pthreads to do multiprocessing
- make MP
+# It is actually not necessary anymore to specify here MP and HYPHYMPI,
+# as 'make' alone will attempt to build them both. However, let's leave
+# them, just in case.
+ make MP HYPHYMPI
make install DESTDIR=$PKG
cd ..