summaryrefslogtreecommitdiffstats
path: root/academic/pianobooster/pianobooster.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/pianobooster/pianobooster.SlackBuild')
-rw-r--r--academic/pianobooster/pianobooster.SlackBuild46
1 files changed, 16 insertions, 30 deletions
diff --git a/academic/pianobooster/pianobooster.SlackBuild b/academic/pianobooster/pianobooster.SlackBuild
index 04b3207a39..5850531d06 100644
--- a/academic/pianobooster/pianobooster.SlackBuild
+++ b/academic/pianobooster/pianobooster.SlackBuild
@@ -2,16 +2,19 @@
# Slackware build script for pianobooster
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Modified by Willy Sudiarto Raharjo <willysr@slackware-id.org>
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210802 bkw: update for v1.0.0 and -current.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pianobooster
-VERSION=${VERSION:-0.6.4b}
-BUILD=${BUILD:-2}
+SRCNAM=PianoBooster
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -23,9 +26,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,43 +54,29 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-src-$VERSION
-tar xvf $CWD/$PRGNAM-src-$VERSION.tar.gz
-cd $PRGNAM-src-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# remove unneeded flag
- sed -i '/mwindows/d' src/CMakeLists.txt
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ../src
-
- # DSO GL and pthread fix
- sed -i "s/$/-lGL -lpthread/" CMakeFiles/pianobooster.dir/link.txt
-
make VERBOSE=1
make install/strip DESTDIR=$PKG
cd ..
-# Make the .desktop file validate.
-sed -i 's/Education;/&AudioVideo;/' $PKG/usr/share/applications/$PRGNAM.desktop
-
-# Don't need (will install docs manually below).
-rm -rf $PKG/usr/share/doc
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README.txt gplv3.txt license.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM/* \
+ $PKG/usr/share/licenses/$PRGNAM/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/doc/ $PKG/usr/share/licenses/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install