summaryrefslogtreecommitdiffstats
path: root/academic/pysam/pysam.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/pysam/pysam.SlackBuild')
-rw-r--r--academic/pysam/pysam.SlackBuild38
1 files changed, 17 insertions, 21 deletions
diff --git a/academic/pysam/pysam.SlackBuild b/academic/pysam/pysam.SlackBuild
index dcbc06e1a6..17d0db3198 100644
--- a/academic/pysam/pysam.SlackBuild
+++ b/academic/pysam/pysam.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for pysam
-# Copyright 2017-2020 Rob van Nues
+# Copyright 2017-2023 Rob van Nues
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,15 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pysam
-VERSION=${VERSION:-0.16.0.1}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-0.21.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-
-#set which python version to install it for
-PYTHON2=false
-PYTHON3=true
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -75,21 +80,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-### pysam linked to htslib-1.10; SBo-htslib is at 1.11:
-##use system htslib:
-#export HTSLIB_LIBRARY_DIR=/usr/lib$LIBDIRSUFFIX
-#export HTSLIB_INCLUDE_DIR=/usr/include
+# pysam linked to htslib-1.17; SBo-htslib is at 1.18
#the source does not allow 'read' to 'other', which could cause a problem on reloading a Jupyter-notebook
chmod 644 pysam.egg-info/*
-
-if $PYTHON2; then
- python setup.py install --root=$PKG
-fi
-if $PYTHON3; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -105,4 +101,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE