summaryrefslogtreecommitdiffstats
path: root/academic/pysam
diff options
context:
space:
mode:
Diffstat (limited to 'academic/pysam')
-rw-r--r--academic/pysam/pysam.SlackBuild30
-rw-r--r--academic/pysam/pysam.info8
2 files changed, 29 insertions, 9 deletions
diff --git a/academic/pysam/pysam.SlackBuild b/academic/pysam/pysam.SlackBuild
index c2ff916cc9..dcbc06e1a6 100644
--- a/academic/pysam/pysam.SlackBuild
+++ b/academic/pysam/pysam.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pysam
-# Copyright 2017 Rob van Nues
+# Copyright 2017-2020 Rob van Nues
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,10 +24,14 @@
PRGNAM=pysam
-VERSION=${VERSION:-0.15.2}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.16.0.1}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+#set which python version to install it for
+PYTHON2=false
+PYTHON3=true
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -64,13 +68,28 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
+
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ \( -perm 777 -o -perm 775 -o -perm 751 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+### pysam linked to htslib-1.10; SBo-htslib is at 1.11:
+##use system htslib:
+#export HTSLIB_LIBRARY_DIR=/usr/lib$LIBDIRSUFFIX
+#export HTSLIB_INCLUDE_DIR=/usr/include
+
+#the source does not allow 'read' to 'other', which could cause a problem on reloading a Jupyter-notebook
+chmod 644 pysam.egg-info/*
+
+
+if $PYTHON2; then
+ python setup.py install --root=$PKG
+fi
+if $PYTHON3; then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -81,6 +100,7 @@ cp -a \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/academic/pysam/pysam.info b/academic/pysam/pysam.info
index 2951c27d95..724abb43a7 100644
--- a/academic/pysam/pysam.info
+++ b/academic/pysam/pysam.info
@@ -1,10 +1,10 @@
PRGNAM="pysam"
-VERSION="0.15.2"
+VERSION="0.16.0.1"
HOMEPAGE="https://github.com/pysam-developers/pysam"
-DOWNLOAD="https://github.com/pysam-developers/pysam/archive/v0.15.2/pysam-0.15.2.tar.gz"
-MD5SUM="3000f77fd997d864fe551b3001fbac22"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pysam/pysam-0.16.0.1.tar.gz"
+MD5SUM="5b4b73431f2511727f4fef43a67b392e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-Cython"
MAINTAINER="Rob van Nues"
EMAIL="sborg63@disroot.org"