summaryrefslogtreecommitdiffstats
path: root/academic/scipy
diff options
context:
space:
mode:
Diffstat (limited to 'academic/scipy')
-rw-r--r--academic/scipy/README32
-rw-r--r--academic/scipy/scipy.SlackBuild10
2 files changed, 21 insertions, 21 deletions
diff --git a/academic/scipy/README b/academic/scipy/README
index e03678305e..81198ddbe7 100644
--- a/academic/scipy/README
+++ b/academic/scipy/README
@@ -1,24 +1,26 @@
SciPy (pronounced "Sigh Pie") is open-source software for mathematics,
science, and engineering.
-The SciPy library is built to work with NumPy arrays, and provides many
-user-friendly and efficient numerical routines such as routines for
-numerical integration and optimization. Together, they run on all popular
-operating systems, are quick to install, and are free of charge. NumPy
-and SciPy are easy to use, but powerful enough to be depended upon by
-some of the world's leading scientists and engineers.
+The SciPy library is built to work with NumPy arrays, and provides
+many user-friendly and efficient numerical routines such as routines
+for numerical integration and optimization. Together, they run on
+all popular operating systems, are quick to install, and are free of
+charge. NumPy and SciPy are easy to use, but powerful enough to be
+depended upon by some of the world's leading scientists and engineers.
-matplotlib and ipython are nice to have in connection with scipy, but scipy
-does not depend on them.
+matplotlib and ipython are nice to have in connection with scipy, but
+scipy does not depend on them.
-Since ver. 0.14.0 scipy uses SuperLU instead of UMFPACK for solving unsymmetric
-sparse linear systems. If you want to use UMFPACK you must install it in advance
-of numpy and build numpy accordingly (see the README to numpy's SlackBuild).
-Moreover, after installing scipy, you have to install scikit-umfpack, which
-presently is not available on SlackBuilds.org.
+Since ver. 0.14.0 scipy uses SuperLU instead of UMFPACK for solving
+unsymmetric sparse linear systems. If you want to use UMFPACK you
+must install it in advance of numpy and build numpy accordingly (see
+the README to numpy's SlackBuild). Moreover, after installing scipy,
+you have to install scikit-umfpack, which presently is not available on
+SlackBuilds.org.
If you need to build scipy for debugging, set DEBUG=y.
NOTE: If you use this SlackBuild scipy will run with the python version
- provided by Slackware Linux, which is presently 2.7.xx. If you'd like to
- use python 3.x then you have to install scipy3.
+ provided by Slackware Linux, which is presently 2.7.xx. If you'd
+ like to use python 3.x then you have to install scipy with the
+ scipy3 SlackBuild.
diff --git a/academic/scipy/scipy.SlackBuild b/academic/scipy/scipy.SlackBuild
index d317dd0478..043194c101 100644
--- a/academic/scipy/scipy.SlackBuild
+++ b/academic/scipy/scipy.SlackBuild
@@ -30,7 +30,7 @@
PRGNAM=scipy
VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -63,12 +63,10 @@ find -L . \
-exec chmod 644 {} \;
DEBUG=${DEBUG:-no}
-case "$DEBUG" in
- [yY]|[yY][eE][sS]) DEBUG="y" ;;
- *) DEBUG="" ;;
-esac
+DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
-if [ ! "$DEBUG" ]; then
+if [ "$DEBUG" = "N" ]
+then
python setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true