summaryrefslogtreecommitdiffstats
path: root/academic/z3/z3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/z3/z3.SlackBuild')
-rw-r--r--academic/z3/z3.SlackBuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/academic/z3/z3.SlackBuild b/academic/z3/z3.SlackBuild
index 9793ed0be3..af9aa52dad 100644
--- a/academic/z3/z3.SlackBuild
+++ b/academic/z3/z3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for z3
-# Copyright 2019 Nick Smallbone, Gothenburg, Sweden
+# Copyright 2019-2022 Nick Smallbone, Gothenburg, Sweden
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,14 +22,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 20220323 bkw: Modified by SlackBuilds.org:
-# - update for v4.8.12 (previous version failed to build on 32-bit 15.0).
-# - always include python3 bindings (since python3 is in core Slackware now).
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=z3
-VERSION=${VERSION:-4.8.12}
+VERSION=${VERSION:-4.11.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -94,7 +90,8 @@ cd ../doc
python mk_api_doc.py
cd ..
-# Copy the Python3 bindings to python3.X/site-packages.
+# The Python bindings are installed for Python2 by default but work on
+# Python3 too. Copy them to python3.X/site-packages.
PYTHON_VERSION=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
PYLIB=$PKG/usr/lib${LIBDIRSUFFIX}/python${PYTHON_VERSION}/site-packages
mkdir -p $PYLIB
@@ -106,11 +103,11 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- README.md RELEASE_NOTES LICENSE.txt \
+ README.md RELEASE_NOTES.md LICENSE.txt Parameters.md \
$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples
cp -a \
- examples/c examples/c++ examples/maxsat examples/python examples/tptp \
+ examples/c examples/c++ examples/maxsat examples/python examples/tptp examples/SMT-LIB2 \
$PKG/usr/doc/$PRGNAM-$VERSION/examples
find $PKG/usr/doc/$PRGNAM-$VERSION/examples -name CMakeLists.txt -delete
cp -a \