summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
Diffstat (limited to 'academic')
-rw-r--r--academic/cistrome-extra/README9
-rw-r--r--academic/cistrome-extra/cistrome-extra.SlackBuild101
-rw-r--r--academic/cistrome-extra/cistrome-extra.info10
-rw-r--r--academic/cistrome-extra/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/academic/cistrome-extra/README b/academic/cistrome-extra/README
new file mode 100644
index 0000000000..0dd4a06ea4
--- /dev/null
+++ b/academic/cistrome-extra/README
@@ -0,0 +1,9 @@
+The cistrome refers to "the set of cis-acting targets of a trans-
+acting factor on a genome-wide scale, also known as the in vivo
+genome-wide location of transcription factor binding-sites or histone
+modifications". The term cistrome is a portmanteau of cistron + genome
+and was coined by investigators at the Dana-Farber Cancer Institute
+and Harvard Medical School.
+
+This is cistrome-extra apps, part of the Cistrome-Applications-Harvard
+project.
diff --git a/academic/cistrome-extra/cistrome-extra.SlackBuild b/academic/cistrome-extra/cistrome-extra.SlackBuild
new file mode 100644
index 0000000000..9ed2e2046f
--- /dev/null
+++ b/academic/cistrome-extra/cistrome-extra.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for cistrome-extra
+
+# Copyright 2016 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cistrome-extra
+VERSION=${VERSION:-git_20150729_7bcbf79}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=cistrome-cistrome-applications-harvard
+SRCVER=7bcbf7953a8b
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVER
+
+if [ -e $CWD/$SRCVER.zip ]; then
+ unzip $CWD/$SRCVER.zip
+else
+ unzip $CWD/$SRCNAM-$SRCVER.zip
+fi
+
+cd $SRCNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cd cistrome-extra-apps
+python setup.py build
+python setup.py install --root=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Ugene expects this to be called like that
+cd $PKG/usr/bin
+ln -s PCGA.py peak2gene.py
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/cistrome-extra/cistrome-extra.info b/academic/cistrome-extra/cistrome-extra.info
new file mode 100644
index 0000000000..8c5e783971
--- /dev/null
+++ b/academic/cistrome-extra/cistrome-extra.info
@@ -0,0 +1,10 @@
+PRGNAM="cistrome-extra"
+VERSION="git_20150729_7bcbf79"
+HOMEPAGE="http://cistrome.org/"
+DOWNLOAD="https://bitbucket.org/cistrome/cistrome-applications-harvard/get/7bcbf7953a8b.zip"
+MD5SUM="39e85034e56b82eb445bb2a9744c438e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"
diff --git a/academic/cistrome-extra/slack-desc b/academic/cistrome-extra/slack-desc
new file mode 100644
index 0000000000..b67a22461d
--- /dev/null
+++ b/academic/cistrome-extra/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cistrome-extra: cistrome-extra (Cistrome Applications Harvard extra apps)
+cistrome-extra:
+cistrome-extra: This is cistrome-extra, part of the Cistrome-Applications-Harvard
+cistrome-extra: project.
+cistrome-extra:
+cistrome-extra:
+cistrome-extra:
+cistrome-extra:
+cistrome-extra:
+cistrome-extra:
+cistrome-extra: