summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
Diffstat (limited to 'academic')
-rw-r--r--academic/mathics/README13
-rw-r--r--academic/mathics/mathics.SlackBuild16
-rw-r--r--academic/mathics/mathics.info8
-rw-r--r--academic/mathics/setup_py_fixes.diff14
4 files changed, 20 insertions, 31 deletions
diff --git a/academic/mathics/README b/academic/mathics/README
index c4fbe3a365..89bae8e2a1 100644
--- a/academic/mathics/README
+++ b/academic/mathics/README
@@ -1,4 +1,9 @@
-Mathics is a free, light-weight alternative to Mathematica.
-Mathics is a general-purpose online computer algebra system featuring
-Mathematica-compatible syntax and functions. It is backed by highly
-extensible Python code, relying on SymPy for most mathematical tasks.
+Mathics is a free, light-weight alternative to Mathematica. Mathics is
+a general-purpose online computer algebra system featuring Mathematica-
+compatible syntax and functions. It is backed by highly extensible
+Python code, relying on SymPy for most mathematical tasks.
+
+
+Optional Dependency
+
+You can install Cython for some extra functionality/optimizations.
diff --git a/academic/mathics/mathics.SlackBuild b/academic/mathics/mathics.SlackBuild
index b934c26d11..fe30f109d5 100644
--- a/academic/mathics/mathics.SlackBuild
+++ b/academic/mathics/mathics.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mathics
-VERSION=${VERSION:-0.8}
+VERSION=${VERSION:-1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf Mathics-$VERSION
+tar xvf $CWD/Mathics-$VERSION.tar.gz
+cd Mathics-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,8 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/setup_py_fixes.diff
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/academic/mathics/mathics.info b/academic/mathics/mathics.info
index 66919c5b1b..f61f3000c2 100644
--- a/academic/mathics/mathics.info
+++ b/academic/mathics/mathics.info
@@ -1,10 +1,10 @@
PRGNAM="mathics"
-VERSION="0.8"
+VERSION="1.0"
HOMEPAGE="http://www.mathics.org/"
-DOWNLOAD="http://github.com/mathics/Mathics/releases/download/v0.8/mathics-0.8.tar.gz"
-MD5SUM="05d6d1f0af9dc20f267a1d9b1b7b1831"
+DOWNLOAD="https://github.com/mathics/Mathics/archive/v1.0/Mathics-1.0.tar.gz"
+MD5SUM="a0a161a1787093b90b21e73b0d44c0fc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="colorama interruptingcow mpmath ply python-dateutil python-django sympy"
+REQUIRES="colorama mpmath ply python-dateutil python-django-legacy six sympy"
MAINTAINER="David Melik"
EMAIL="dchmelik@gmail.com"
diff --git a/academic/mathics/setup_py_fixes.diff b/academic/mathics/setup_py_fixes.diff
deleted file mode 100644
index be399022f8..0000000000
--- a/academic/mathics/setup_py_fixes.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur mathics-0.8/setup.py mathics-0.8.patched/setup.py
---- mathics-0.8/setup.py 2015-05-30 20:15:49.000000000 -0700
-+++ mathics-0.8.patched/setup.py 2015-06-27 18:41:36.237193840 -0700
-@@ -61,8 +61,8 @@
- INSTALL_REQUIRES = ['cython>=0.15.1']
-
- # General Requirements
--INSTALL_REQUIRES += ['sympy==0.7.6', 'django >= 1.6, < 1.7', 'ply>=3.6',
-- 'mpmath>=0.19', 'argparse', 'python-dateutil', 'colorama',
-+INSTALL_REQUIRES += ['sympy==0.7.6', 'django >= 1.6', 'ply>=3.6',
-+ 'mpmath>=0.19', 'python-dateutil', 'colorama',
- 'interruptingcow']
-
- # if sys.platform == "darwin":