summaryrefslogtreecommitdiffstats
path: root/audio/bristol
diff options
context:
space:
mode:
Diffstat (limited to 'audio/bristol')
-rw-r--r--audio/bristol/03-rm_alsa-iatomic.h.patch26
-rw-r--r--audio/bristol/bristol.SlackBuild4
2 files changed, 30 insertions, 0 deletions
diff --git a/audio/bristol/03-rm_alsa-iatomic.h.patch b/audio/bristol/03-rm_alsa-iatomic.h.patch
new file mode 100644
index 0000000000..a7357643d8
--- /dev/null
+++ b/audio/bristol/03-rm_alsa-iatomic.h.patch
@@ -0,0 +1,26 @@
+Description: Stop using alsa/iatomic.h
+ Technically this is an API breakage in libasound 1.1.2,
+ but it makes sense to me that this header was removed
+ by ALSA upstream.
+ .
+ bristol was the only user in Debian, and even here the
+ code that once used it was already commented out.
+Author: Adrian Bunk <bunk@stusta.de>
+Reviewed-by: James Cowgill <jcowgill@debian.org>
+ Herbert Parentes Fortes Neto <hpfn@debian.org>
+Bug-Debian: https://bugs.debian.org/834180
+Forwarded: no
+Index: bristol-0.60.11/libbristolaudio/audioEngineJack.c
+===================================================================
+--- bristol-0.60.11.orig/libbristolaudio/audioEngineJack.c
++++ bristol-0.60.11/libbristolaudio/audioEngineJack.c
+@@ -38,9 +38,6 @@
+ #include <string.h>
+
+ #ifdef _BRISTOL_JACK
+-#if (BRISTOL_HAS_ALSA == 1)
+-#include <alsa/iatomic.h>
+-#endif
+
+ /*
+ * Drop this atomic stuff, it comes from the ALSA library and it not present on
diff --git a/audio/bristol/bristol.SlackBuild b/audio/bristol/bristol.SlackBuild
index 6f556558d7..568cc54b40 100644
--- a/audio/bristol/bristol.SlackBuild
+++ b/audio/bristol/bristol.SlackBuild
@@ -7,6 +7,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20170621 bkw: fix build on -current
# 20141030 bkw: make VERSION respect environment
PRGNAM=bristol
@@ -56,6 +57,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Patch from Debian to fix alsa-lib API breakage.
+patch -p1 < $CWD/03-rm_alsa-iatomic.h.patch
+
# Hard-coded /usr/lib and /usr/X11R6/lib sucks.
sed -i "s,/usr/lib,/usr/lib$LIBDIRSUFFIX,g" \
configure Makefile.* brighton/Makefile.* libbrightonX11/Makefile.*