summaryrefslogtreecommitdiffstats
path: root/audio/faac/faac.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/faac/faac.SlackBuild')
-rw-r--r--audio/faac/faac.SlackBuild72
1 files changed, 18 insertions, 54 deletions
diff --git a/audio/faac/faac.SlackBuild b/audio/faac/faac.SlackBuild
index 5c7cec7f5d..9f267909b9 100644
--- a/audio/faac/faac.SlackBuild
+++ b/audio/faac/faac.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for faac
# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
+# Copyright (c) 2020, Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -26,13 +27,15 @@
# Updated to newer version by Niklas "Nille" Åkerström and also new maintainer.
PRGNAM=faac
-VERSION=${VERSION:-1.28}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-1.30}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCVER=${VERSION/./_}
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +46,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -57,57 +60,25 @@ else
LIBDIRSUFFIX=""
fi
-# Seems that libmp4v2 is a complicated critter. Here's how we think it works:
-#
-# libmp4v2:installed, --with-mp4v2: faac uses external libmp4v2
-# libmp4v2:not installed, --with-mp4v2: faac uses internal libmp4v2
-# libmp4v2:installed, --without-mp4v2: faac uses external libmp4v2
-# libmp4v2:not installed, --without-mp4v2: faac doesn't use any libmp4v2
-#
-# Therefore, we'll default to use --without-mp4v2, which should produce the
-# desired result in every case *except* where one wants to use the internal
-# implementation, and that creates other problems, so we don't support it.
-#
-# From what used to be in our README:
-# faac comes with its own version of libmp4v2, but if you use it, you have to
-# uninstall faac everytime you want to update it, as faac would otherwise
-# detect the already installed libmp4v2 and build against it. Then, when you
-# upgrade to the new package, it doesn't have the included libmp4v2, because
-# it was part of the old package, so faac is linking to a nonexistent library
-# after the upgrade.
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-May/005680.html
-# Fix compilation problem faac-1.28 and external libmp4v2 1.9.1
-# see http://sourceforge.net/tracker/?func=detail&aid=2894310&group_id=704&atid=100704
-# and http://ftp.eenet.ee/gentoo-portage/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
-patch -p1 < $CWD/faac-1.28-external-libmp4v2.patch
-
-# http://sourceforge.net/p/faac/bugs/174/
-patch -p0 < $CWD/faac-1.28-libmp4v2_r479_compat.patch
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix for automake >= 1.13
-sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.in || die
+sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
-# having just patched configure.in, we need to bludgeon automake
-libtoolize --force --copy
-aclocal
-autoconf
-automake --add-missing
+./bootstrap
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -117,7 +88,6 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--enable-shared=yes \
--enable-static=no \
- --without-mp4v2 \
--build=$ARCH-slackware-linux
make
@@ -127,18 +97,12 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO docs/* \
+cp -a AUTHORS ChangeLog COPYING NEWS README TODO docs/*.{html,pdf} \
$PKG/usr/doc/$PRGNAM-$VERSION
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/faac.1
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
-if [ "$1" = "--cleanup" ]; then
- rm -rf $PKG $TMP/$PRGNAM-$VERSION
-fi