summaryrefslogtreecommitdiffstats
path: root/audio/jaaa/jaaa.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jaaa/jaaa.SlackBuild')
-rw-r--r--audio/jaaa/jaaa.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/jaaa/jaaa.SlackBuild b/audio/jaaa/jaaa.SlackBuild
index 2bb62dbb9e..541d2d908a 100644
--- a/audio/jaaa/jaaa.SlackBuild
+++ b/audio/jaaa/jaaa.SlackBuild
@@ -7,7 +7,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=jaaa
-VERSION=${VERSION:-0.8.4}
+VERSION=${VERSION:-0.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,11 +47,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
@@ -60,6 +57,9 @@ if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
source/Makefile
fi
+# where does "pkgconf" come from?
+sed -i 's,pkgconf,pkg-config,' source/Makefile
+
make -C source $PRGNAM install PREFIX=/usr DESTDIR=$PKG
strip $PKG/usr/bin/$PRGNAM