summaryrefslogtreecommitdiffstats
path: root/audio/jack-tools/jack-tools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jack-tools/jack-tools.SlackBuild')
-rw-r--r--audio/jack-tools/jack-tools.SlackBuild31
1 files changed, 6 insertions, 25 deletions
diff --git a/audio/jack-tools/jack-tools.SlackBuild b/audio/jack-tools/jack-tools.SlackBuild
index de051222a1..70524f89a8 100644
--- a/audio/jack-tools/jack-tools.SlackBuild
+++ b/audio/jack-tools/jack-tools.SlackBuild
@@ -4,8 +4,6 @@
# Written by B. Watson (yalhcru@gmail.com)
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
# 20151110 bkw:
# - Updated for 20141211. This is the date of the latest darcs
# commit. Note that the c-common/ in the source tarball is the
@@ -14,16 +12,10 @@
# and jack-play have changed.
# - Add capability stuff.
-# 20170127 bkw:
-# - Updated for 20170117 (latest commit). Also updated c-common to
-# latest.
-# - Added man pages for the new jack-data and jack-lxvst utils.
-# - Added VST headers to get jack-lxvst to build. Not sure the
-# licensing status of these, but they were cloned from a public
-# github repo.
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=jack-tools
-VERSION=${VERSION:-20170117}
+VERSION=${VERSION:-20141211}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,29 +52,18 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}-$VERSION.tar.xz
+tar xvf $CWD/${PRGNAM}-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-# apply our flags. -Wl,-s strips the binaries.
-sed -i "s/-O./$SLKCFLAGS -Wl,-s/" Makefile c-common/Makefile
-
-# Slackware doesn't have libtinfo
-sed -i 's,-ltinfo,,' Makefile
-
-# Author's library
+sed -i "s,-O.,$SLKCFLAGS," Makefile c-common/Makefile
make -C c-common
-
-# Steinberg VST headers, from:
-# https://github.com/RomanKubiak/ctrlr/tree/master/VST/pluginterfaces/vst2.x
-mkdir -p pluginterfaces/vst2.x
-cp $CWD/*.h pluginterfaces/vst2.x
-
make
mkdir -p $PKG/usr/bin $PKG/usr/include
make install prefix=$PKG/usr
+strip $PKG/usr/bin/*
-# man pages generated from *.md markdown files, then manually edited
+# man pages generated from *.ad asciidoc files, then manually edited
# to clean up the formatting.
mkdir -p $PKG/usr/man/man1
for page in $CWD/man/*.1; do