summaryrefslogtreecommitdiffstats
path: root/audio/jack1/jack1.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jack1/jack1.SlackBuild')
-rw-r--r--audio/jack1/jack1.SlackBuild58
1 files changed, 46 insertions, 12 deletions
diff --git a/audio/jack1/jack1.SlackBuild b/audio/jack1/jack1.SlackBuild
index 2b2896b664..2d908b69af 100644
--- a/audio/jack1/jack1.SlackBuild
+++ b/audio/jack1/jack1.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Slackware build script for jack1-legacy, adapted from
+# Slackware build script for jack1, adapted from
# jack-audio-connection-kit.SlackBuild.
# Copyright 2007-2014 Heinz Wiesinger, Amsterdam, The Netherlands
@@ -26,21 +26,26 @@
# Modified by Robby Workman <rworkman@slackbuilds.org>
# No additional license terms added :)
-# Modified, renamed, and now maintained by B. Watson <yalhcru@gmail.com>
+# Modified, renamed, and now maintained by B. Watson <urchlay@slackware.uk>
# This build was renamed from jack-audio-connection-kit to jack1.
# If you need to see the commit log for the old name, use a command like:
# git log -- audio/jack-audio-connection-kit
+# 20240319 bkw: updated for v0.126.0. since upstream moved the tools
+# to a separate git repo, modified this build to include that as well,
+# for compatibility with older releases.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jack1
-VERSION=${VERSION:-0.125.0}
+VERSION=${VERSION:-0.126.0}
+TOOLSVER=${TOOLSVER:-4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=jack-audio-connection-kit
+SRCNAM=$PRGNAM
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -50,9 +55,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -84,9 +86,11 @@ cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
+TOPDIR="$(pwd)"
+tar xvf $CWD/jack-example-tools-$TOOLSVER.tar.gz
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# respect march and mtune flags: fixes building on x86_64
sed -i 's|-march=native \-mtune=native||' configure.ac
@@ -109,11 +113,41 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install-strip DESTDIR=$PKG
+# 20240319 bkw: now build the tools against the installed libs in $PKG.
+cd $TOPDIR
+sed "s,/usr,$PKG/usr,g" $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/jack.pc > jack.pc
+export PKG_CONFIG_PATH=$TOPDIR:$PKG_CONFIG_PATH
+cd jack-example-tools-$TOOLSVER
+mkdir build
+MFLAGS="$SLKCFLAGS -I$PKG/usr/include"
+cd build
+ CFLAGS="$MFLAGS" \
+ CXXFLAGS="$MFLAGS" \
+ LDFLAGS="-L$PKG/usr/lib$LIBDIRSUFFIX" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+
gzip -9 $PKG/usr/man/man?/*.?
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING* README TODO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+PKGDOC2=$PKGDOC/jack-example-tools-$TOOLSVER
+mkdir -p $PKGDOC $PKGDOC2
+cp -a LICENSE *.md $PKGDOC2
+cd $TOPDIR
+cp -a AUTHORS COPYING* README.md TODO $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+rm -f $PKG/usr/lib*/*.la
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc