summaryrefslogtreecommitdiffstats
path: root/audio/lash/lash.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/lash/lash.SlackBuild')
-rw-r--r--audio/lash/lash.SlackBuild35
1 files changed, 25 insertions, 10 deletions
diff --git a/audio/lash/lash.SlackBuild b/audio/lash/lash.SlackBuild
index 281ad2b76e..1279c3129a 100644
--- a/audio/lash/lash.SlackBuild
+++ b/audio/lash/lash.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for lash
@@ -24,11 +24,14 @@
# YOUR DATA IS DESTROYED, YOUR HOUSE BURNS DOWN OR YOUR DOG RUNS OFF.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=lash
VERSION=${VERSION:-0.6.0.594}
SOURCE=$PRGNAM-0.6.0~rc2
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-6}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -38,7 +41,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -72,15 +82,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if [ "$(/usr/share/texmf/bin/texi2html --version 2>/dev/null)" != "1.76" ]; then
- patch -p1 --verbose < $CWD/texlive.patch
-fi
+#if [ "$(/usr/share/texmf/bin/texi2html --version 2>/dev/null)" != "1.76" ]; then
+# patch -p1 --verbose < $CWD/texlive.patch
+#fi
-if $( which texi2html >/dev/null 2>&1 ); then
- manual=docs/lash-manual-html-one-page/lash-manual.html
+if [ -x /usr/bin/texi2html ]; then
+ manual=docs/lash-manual-html-one-page/lash-manual.html
+ sed -i "s,texi2html --number,&-sections,g" docs/Makefile.in
fi
-CFLAGS="$SLKCFLAGS" \
+export LDFLAGS="-ldl -lm -ltirpc"
+
+CFLAGS="$SLKCFLAGS -I/usr/include/tirpc" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -104,8 +117,10 @@ cp AUTHORS README.SECURITY COPYING ChangeLog ChangeLog.old NEWS INSTALL README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -f $PKG/usr/lib*/*.la
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE