summaryrefslogtreecommitdiffstats
path: root/audio/lv2
diff options
context:
space:
mode:
Diffstat (limited to 'audio/lv2')
-rw-r--r--audio/lv2/lv2.SlackBuild48
-rw-r--r--audio/lv2/lv2.info6
2 files changed, 38 insertions, 16 deletions
diff --git a/audio/lv2/lv2.SlackBuild b/audio/lv2/lv2.SlackBuild
index 2d640930c8..7d6ac143a8 100644
--- a/audio/lv2/lv2.SlackBuild
+++ b/audio/lv2/lv2.SlackBuild
@@ -1,9 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for lv2core
# Copyright 2008-2016 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2020 Matteo Bernardini, Pisa, Italy
+# Copyright 20202023 Matteo Bernardini, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=lv2
-VERSION=${VERSION:-1.18.0}
+VERSION=${VERSION:-1.18.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -61,7 +71,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -70,13 +80,25 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-./waf configure \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --lv2dir=/usr/lib$LIBDIRSUFFIX/lv2
-
-./waf build
-./waf install --destdir=$PKG
+sed -i meson.build -e "s|^lv2_docdir.*|lv2_docdir = '/usr/doc/$PRGNAM-$VERSION'|"
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dlv2dir=/usr/lib${LIBDIRSUFFIX}/lv2 \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
mkdir -p $PKG/etc/profile.d
@@ -104,4 +126,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/lv2/lv2.info b/audio/lv2/lv2.info
index 09b68a0503..6d0eba5a1e 100644
--- a/audio/lv2/lv2.info
+++ b/audio/lv2/lv2.info
@@ -1,8 +1,8 @@
PRGNAM="lv2"
-VERSION="1.18.0"
+VERSION="1.18.10"
HOMEPAGE="http://lv2plug.in/"
-DOWNLOAD="http://lv2plug.in/spec/lv2-1.18.0.tar.bz2"
-MD5SUM="e5cd231b43bd2b114e43ebab68861d99"
+DOWNLOAD="http://lv2plug.in/spec/lv2-1.18.10.tar.xz"
+MD5SUM="9c1f3143ea2eea341e8d6e1bad9e5e0e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="sord"