summaryrefslogtreecommitdiffstats
path: root/audio/qjackctl/qjackctl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/qjackctl/qjackctl.SlackBuild')
-rw-r--r--audio/qjackctl/qjackctl.SlackBuild45
1 files changed, 27 insertions, 18 deletions
diff --git a/audio/qjackctl/qjackctl.SlackBuild b/audio/qjackctl/qjackctl.SlackBuild
index 16a3ccedbd..1d7ff53113 100644
--- a/audio/qjackctl/qjackctl.SlackBuild
+++ b/audio/qjackctl/qjackctl.SlackBuild
@@ -4,7 +4,8 @@
# Copyright 2009, Erik W. Hanson, Minneapolis, MN, USA
# Copyright 2012, James M. Brewster, Baltimore, MD, USA
-# Copyright 2014-2016 Marcel Saegebarth <marc@mos6581.de>
+# Copyright 2014-2016 Marcel Saegebarth <email removed>
+# Copyright 2020 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,8 +25,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20210306 bkw: update for v0.9.1.
+# 20201218 bkw: update for v0.9.0.
+
+# 20200204 bkw:
+# - take over maintenance
+# - update for v0.6.1
+# - fix French man page
+
PRGNAM=qjackctl
-VERSION=${VERSION:-0.4.5}
+VERSION=${VERSION:-0.9.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,16 +74,12 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Tell qmake about our SLKCFLAGS. Required to compile on x86_64
-# system. Thanks to Lyle Sigurdson <lyle@sent.com> on
-# linuxquestions.org for this patch.
-echo "QMAKE_CXXFLAGS_RELEASE=$SLKCFLAGS" >> qjackctl.pro.in
+# 20201218 bkw: it's tripping over qt4's qmake, so force the issue:
+sed -i 's|\<qmake,|qmake-qt5,|' configure.ac
+autoreconf -if
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -88,18 +93,22 @@ CFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+strip $PKG/usr/bin/$PRGNAM
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# man pages already compressed, but the French one needs a little help
+# to respect LANG=fr_FR or LANG=fr_FR.UTF-8 in the env.
+mkdir -p $PKG/usr/man/fr.UTF-8/man1 $PKG/usr/man/fr/man1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+# This works only for man-db (which becomes the stock man command in 15.0).
+ln -s ../../man1/$PRGNAM.fr.1.gz $PKG/usr/man/fr.UTF-8/man1/$PRGNAM.1.gz
-# Make sure we have a standard-compliant desktop file
-cat $CWD/qjackctl.desktop > $PKG/usr/share/applications/qjackctl.desktop
+# This works for 14.2's man command, which doesn't grok the fullness of utf-8.
+iconv -f UTF-8 -t ISO-8859-1 $PRGNAM.fr.1 | \
+ gzip -9c > \
+ $PKG/usr/man/fr/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog INSTALL README TODO TRANSLATORS \
+cp -a AUTHORS COPYING ChangeLog README TODO TRANSLATORS \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild