summaryrefslogtreecommitdiffstats
path: root/audio/sonic-visualiser/sonic-visualiser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/sonic-visualiser/sonic-visualiser.SlackBuild')
-rw-r--r--audio/sonic-visualiser/sonic-visualiser.SlackBuild71
1 files changed, 15 insertions, 56 deletions
diff --git a/audio/sonic-visualiser/sonic-visualiser.SlackBuild b/audio/sonic-visualiser/sonic-visualiser.SlackBuild
index c00d915fa8..e166c6ba11 100644
--- a/audio/sonic-visualiser/sonic-visualiser.SlackBuild
+++ b/audio/sonic-visualiser/sonic-visualiser.SlackBuild
@@ -6,6 +6,16 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20181217 bkw:
+# - Update for 3.2. This was left stale for a long time due to
+# problems with SBo's old qt5, which has finally been updated,
+# thanks to dive.
+# - Get rid of static capnproto, no longer needed (thank the ghods).
+# - PulseAudio now works, update README accordingly.
+# - Yes, I'm aware that it's segfaulting on exit, but it won't dump
+# core (even though I have coredumps enabled) so I can't easily
+# diagnose it.
+
# 20170312 bkw:
# - update for 3.0.1
# - parallel build seems OK, remove -j1 (again)
@@ -38,7 +48,7 @@
# - add realtime capabilities
PRGNAM=sonic-visualiser
-VERSION=${VERSION:-3.0.1}
+VERSION=${VERSION:-3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,65 +82,14 @@ fi
set -e
rm -rf $PKG $TMP/$PRGNAM
-mkdir -p $TMP/$PRGNAM $PKG $OUTPUT
-
-# use a top-level dir under $TMP for ease of cleanup.
-cd $TMP/$PRGNAM
-
-# Grrr. Upstream requires a git version of capnproto, newer than the
-# latest release. They *really* should bundle it, or at least mention it
-# in their README or INSTALL.txt, if they're going to depend on bleeding
-# edge stuff... the only way to understand what's going on here is to
-# actually read the comments in configure.ac. We have to build a static
-# capnproto and force sonic-visualiser to use it.
-LIBVER="${LIBVER:-86ce27924ceae700a70a00963aaab3766d26b348}"
-LIBNAM=capnproto
-LIBPREFIX=$TMP/$PRGNAM/$LIBNAM
-
-rm -rf $LIBNAM-$LIBVER
-tar xvf $CWD/$LIBNAM-$LIBVER.tar.gz
-cd $LIBNAM-$LIBVER
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# following code borrowed & modified from capnproto.SlackBuild by
-# Andre Barboza:
-cd c++
- autoreconf -ivf
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=$LIBPREFIX \
- --disable-shared \
- --enable-static \
- --build=$ARCH-slackware-linux
-
- # don't run ldconfig. not needed (a) because of --disabled-shared,
- # and (b) we're installing into a non-system directory anyway.
- sed -i '/^\t*ldconfig/d' Makefile
-
- make
- make install-strip
-cd ..
-
-# These will be used by sonic-visualiser's ./configure:
-export PKG_CONFIG_PATH=$LIBPREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
-export PATH=$LIBPREFIX/bin:$PATH
-
-cd $TMP/$PRGNAM
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
QTDIR=$QT5DIR \
CFLAGS="$SLKCFLAGS" \